WordPress.org

Ready to get started?Download WordPress

Forums

Google Maps Widget
[resolved] Light box feature (38 posts)

  1. aldaw
    Member
    Posted 1 year ago #

    I installed Google Maps Widget on a premium template and the lightbox feature didn't work. I installed it previously on the 2011 theme and works fine. Can you help? Site URL: http://timsmithmarineservices.com/

    Thanks,
    Al Daw

    http://wordpress.org/extend/plugins/google-maps-widget/

  2. WebFactory
    Member
    Plugin Author

    Posted 1 year ago #

    Your sidebar markup is not respecting the usual widget naming convention so our JS is unable to target the widget link. Contact us via email and we'll shoot you some custom code to fix the problem.

  3. WebFactory
    Member
    Plugin Author

    Posted 1 year ago #

    Open gmw.js and change
    $('.google-maps-widget a.widget-map').click(function() {
    to
    $('a.widget-map').click(function() {

  4. aldaw
    Member
    Posted 1 year ago #

    Thanks WebFactory,

    I love this plugin and the code you provided above works perfectly.
    Thanks a bunch,
    Al

  5. WebFactory
    Member
    Plugin Author

    Posted 1 year ago #

    You're welcome!

  6. MBA
    Member
    Posted 1 year ago #

    Dear WebFactory

    I installed Google Maps Widget on a template (widely) and the lightbox feature didn't work. I installed the last update too but still doesn't working the lightbox. Can you help? Site URL: http://www.tathyemarcos.info

    PS. LOGIN and PSW: bulbow

    Best Regards,
    Marcos

  7. WebFactory
    Member
    Plugin Author

    Posted 1 year ago #

    Apply the fix noted above and if necessary disable Balupton lightbox plugin.

  8. MBA
    Member
    Posted 1 year ago #

    Sorry, I fix the noted above and disable the Balupton lightbox plugin but it doesn't work... :(

    You've other ideia how I solve the problem??

    Thanks a lot!
    MBA

  9. WebFactory
    Member
    Plugin Author

    Posted 1 year ago #

    There's another fancybox script included which is causing fatal JS errors
    /wp-content/themes/widely/script/fancybox/jquery.fancybox-1.3.4.js?ver=3.4.2 + you have a really, really old jQuery core included.

  10. MBA
    Member
    Posted 1 year ago #

    Hi WebFactory!

    I change the jquery.fancybox-1.3.4.js and others .js too to new version that I find here (http://fancyapps.com/fancybox/) - (I copy and paste with the same name...) and now your plugin Google Maps Widget working!!! Thanks!! However the modal(mask) doesn't back when I click outside... Please can you help me for discovery what's happens now?!!

    Thanks!!

  11. WebFactory
    Member
    Plugin Author

    Posted 1 year ago #

    Remove the extra jquery.fancybox-1.3.4.css included CSS files.

  12. SamAsh
    Member
    Posted 1 year ago #

    Hi - first off great Map Widget :)

    Just wondering if you can help? I installed it a few weeks back and all was fine - I just updated and now when you click on the small map the large map looks grayed out? - I'm using chrome - but was working perfect last week.

    An help would be much appreciated.

    http://www.completewellington.co.nz/testsite/contact-us/

  13. WebFactory
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, I can't see any problems whatsoever. Try force refreshing the browser cache. Map is not grayed out; area around it is and it should be.

  14. SamAsh
    Member
    Posted 1 year ago #

    Hi - Thanks heaps - not sure why it is still doing it from this end? - I have force refreshed and cleared the cache but still looks the same?

    Guess it's not really a problem as long as other people are seeing it correctly :)

    Thanks anyway

  15. WebFactory
    Member
    Plugin Author

    Posted 1 year ago #

    You're welcome. Snap a screenshot, 'cause it's very difficult to fix something we can't see :) Also, does it work for you in other browsers?

  16. SamAsh
    Member
    Posted 1 year ago #

    Hi - I checked it in ie, firefox all looks fine - must be a chrome issue? I could try a fresh install of chrome and see if that fixes it.

    Btw this is a screen of what I see http://www.completewellington.co.nz/screen.jpg

  17. WebFactory
    Member
    Plugin Author

    Posted 1 year ago #

    It definitely looks like an z-index overlay issue but I can't reproduce it and therefore can't fix it :(

    Enable Chrome debugger (Ctrl+Shift+I). Under its setting disable cache and then hit Shift+F5. If that doesn't help .... I really don't know :(

  18. SamAsh
    Member
    Posted 1 year ago #

    Thanks for the tip - I ran the Ctrl+Shift+I and found the CSS for .fancybox-overlay {

    So what I have found... I unchecked the "z-index: 98010;" it works perfectly! Very odd :)

  19. SamAsh
    Member
    Posted 1 year ago #

    Just did the edit on the css and it still seems to be working! looks good in Chrome again - just have a look when you get time and let me know if you see it looking ok still :)

    Thanks again for your help

  20. WebFactory
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, it looks good.

    You're welcome. Please give the plugin 5 starts at http://wordpress.org/extend/plugins/google-maps-widget/ if you can. It helps a lot. Thanks!

  21. SamAsh
    Member
    Posted 1 year ago #

    Done :)

  22. WebFactory
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks!

  23. majorsd
    Member
    Posted 1 year ago #

    Dear WebFactory,

    I updated the google widget but now I am having problems with the lightbox. Any help?

    http://www.themajorslaw.com

    thank you

  24. WebFactory
    Member
    Plugin Author

    Posted 1 year ago #

    You're using a very old and non WP-native version of jQuery. Switch to jQuery bundled with WP and everything should be fine.

  25. jmoffat_gc
    Member
    Posted 1 year ago #

    Running into the same issues for a site i'm helping build:

    http://www.friendsplayhousechildcare.com

    Tried the fixes but it's just not working for me. Help?!?

  26. WebFactory
    Member
    Plugin Author

    Posted 1 year ago #

    Fancybox JS is loaded twice. Either disable it in the theme or in our plugin (you'll have to edit a bit of PHP either way).

  27. theanimalix
    Member
    Posted 1 year ago #

    Good job making a nice, simple and easy to use plugin. Still, I have similar problem then others, when clicking on the map, nothing happens. Could you please check my site http://www.thebossreviews.net ?

  28. WebFactory
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you.

    Replace the custom (and old, v1.4.2) jQuery with the default WP one and everything will be fine&dandy :)

  29. theanimalix
    Member
    Posted 1 year ago #

    I have located the part of code where jQuery is included (index.php of the theme), but what should I replace it with?

    Here is the code:

    <?php if($enable_nivo_jquery){
    
                echo '<script src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js" type="text/javascript"></script>';
    
                }?>

    Thanks for helping.

  30. WebFactory
    Member
    Plugin Author

    Posted 1 year ago #

    That's simply wrong. It goes against WP coding standards and doesn't allow other plugins to work properly.

    You can try with http://ajax.googleapis.com/ajax/libs/jquery/1.8.2/jquery.min.js.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.