WordPress.org

Ready to get started?Download WordPress

Forums

Store Locator Plus
[resolved] Warning: is_readable() [function.is-readable]: open_bas (10 posts)

  1. Michellebc
    Member
    Posted 2 years ago #

    After I activate the plugin the whole site is working inproperly.
    The home page a warning message at the top:
    Warning: is_readable() [function.is-readable]: open_basedir restriction in effect. File(/home/locksmit/public_html/mrlocksmiths.ca/wp-content/plugins/store-locator-le/store-locator-le.php/core/languages/csl-slplus-en_US.mo) is not within the allowed path(s): (/home/locksmit:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp) in /home/locksmit/public_html/mrlocksmiths.ca/wp-includes/l10n.php on line 339

    I have search the Plugin support forum and see other has a similar problem for few months now but there is no solution.

    http://wordpress.org/extend/plugins/store-locator-le/

  2. Cyber Sprocket Labs
    Member
    Posted 2 years ago #

    That sounds like a wordpress issue being unable to open language files ... sadly there's not much we can do about it on our end.

  3. Michellebc
    Member
    Posted 2 years ago #

    It seems to me that your code is looking for a wrong file path.
    It is looking for /home/locksmit/public_html/mrlocksmiths.ca/wp-content/plugins/store-locator-le/store-locator-le.php/core/languages/csl-slplus-en_US.mo
    I find it hard to believe you have files under a folder named store-locator-le.php

  4. Cyber Sprocket Labs
    Member
    Posted 2 years ago #

    er, well, you never know what crazy things programmers will try :D But seriously, that's really odd. Can you think of anything that would cause this to happen on that install and not another? I'm checking it out on my end to see if there's a typo somewhere ...

  5. phoebe007
    Member
    Posted 2 years ago #

    I get the same error. Mine is:

    Warning: is_readable() [function.is-readable]: open_basedir restriction in effect. File(/home/happyski/public_html/wp-content/plugins/store-locator-le/store-locator-le.php/core/languages/csl-slplus-en_US.mo) is not within the allowed path(s): (/home/happyski:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp) in /home/happyski/public_html/wp-includes/l10n.php on line 339
    
    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/happyski/public_html/wp-includes/l10n.php:339) in /home/happyski/public_html/wp-content/plugins/facebook-awd/inc/classes/facebook/facebook.php on line 37

    Looking forward to hearing about a resolution :) Thanks

  6. Cyber Sprocket Labs
    Member
    Posted 2 years ago #

    modify the open_basedir settings on your httpd configuration file.

    The open_base_dir setting is primarily used to prevent php scripts for a particular user from accessing files in another user's account. So usually, any files in your own account should be readable by your own scripts

    php_admin_value open_basedir "/home/happyski/public_html/wp-content/plugins/store-locator-le/store-locator-le.php/core/languages/"

  7. Cyber Sprocket Labs
    Member
    Posted 2 years ago #

    Also, make sure you are NOT running PHP4. PHP4 and our plugin (as well as newer versions of WordPress) do not get along.

  8. phoebe007
    Member
    Posted 1 year ago #

    Thanks for taking the time to reply but this fix didn't work for me, I still get the same error.

    I suspect that it's not a permissions issue but the code is looking for the files in the wrong place

    ie.. This code is treating a php file as a directory:

    /home/happyski/public_html/wp-content/plugins/store-locator-le/store-locator-le.php/core/languages/

  9. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    modify the open_basedir settings on your httpd configuration file.

    The open_base_dir setting is primarily used to prevent php scripts for a particular user from accessing files in another user's account. So usually, any files in your own account should be readable by your own scripts

    php_admin_value open_basedir "/home/happyski/public_html/:/tmp/:/"

    "This code" that you are referring to is the WordPress core engine and is using the language file settings. We are not doing anything special/unique with language file translations. This is an HTTP or SELinux configuration issue on the server. Permissions are not set correctly in one of those places or in your WordPress content directory(ies).

  10. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    We may have found the problem v3.2 due next week should fix it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.