WordPress.org

Ready to get started?Download WordPress

Forums

Store Locator Plus
[resolved] Map doesn't load (20 posts)

  1. Saabana
    Member
    Posted 1 year ago #

  2. Saabana
    Member
    Posted 1 year ago #

    Solved

  3. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    How did you resolve the issue?

  4. MJHines
    Member
    Posted 1 year ago #

    I am curious as well. Was it an issue with your custom theme?

  5. Saabana
    Member
    Posted 1 year ago #

  6. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the tip!

    A lot of people are having issues with the Google Maps not displaying and the API V2 and API V3 conflicts.

  7. intlistsys
    Member
    Posted 1 year ago #

    I have tried this solution. It does not work. Anyone else?

  8. Saabana
    Member
    Posted 1 year ago #

    in step 2/ go to services turn on google maps API v3 only.
    remember to 3/go to API Access and delete all key in there.
    4/ Create new Browser key...

    copy and paste your new API key
    and wait like 2 minutes, now map should load

  9. intlistsys
    Member
    Posted 1 year ago #

    Thanks, it's still not working for us, though. I've followed your steps from start to finish twice.

    1. Turn off all API
    2. Turn on only Maps V3 API
    3. Delete API key (there is only one)
    4. Issue new API key
    5. Copy/paste API key into store locator
    6. Refresh

    The map loads, but not every time, maybe 5/6 out of 10. Unfortunately, our clients are not going to hit refresh until it pops up. Any other ideas?

  10. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    Provide a site URL so we can investigate/monitor the situation.

  11. intlistsys
    Member
    Posted 1 year ago #

  12. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    @intlistsys

    Your theme has multiple errors. Use Firefox with Firebug and turn on the console, script, and network panels.

    themes/ils/images/icon_book.png, icon_speechbubbles.png, and icon_podium.png are missing. These each cause significant page loading delays (6-7 seconds each) which can cause other connections (like the Google Maps API connection) to time out.

    Also, QuotaService.RecordEvent is taking nearly 1 minute to load. Sometimes longer. If it goes over 90 seconds there is a very good chance many other scripts will fail with a timeout, including Google scripts.

    I'm not sure what QuotaService is, but it is not playing well with others.

  13. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    @intlistsys

    Looks like you have multiple calls to Google that are being blocked or not honored properly. A firewall setting or something not set on your Google API correctly.

    csi.gstatic.com and maps.googleapis.com (QuotaService) are both being called but are not responding in less than a minute. That is not normal and appears to be a connectivity issue between your server and Google. Most likely security or account settings.

  14. rkolpien
    Member
    Posted 1 year ago #

    I appear to be having similar issues from our site -

    http://celebraterecoveryindiana.org

    I'm really stuck and not sure where to even begin here.

  15. Cinetics
    Member
    Posted 1 year ago #

    Hi CSA,

    I've had no luck with Maps V3 API or with both Maps V2 & V3 APIs.

    You said, "Use Firefox with Firebug and turn on the console, script, and network panels." What are the next steps?

  16. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    @Cinetics -

    Look for JavaScript errors. Make sure the store-locator-le csl.js is loaded. Most often another script is failing or blocking the Store Locator Plus script. Errors and conflicts should be obvious with Firebug console turned on.

  17. Websolo
    Member
    Posted 1 year ago #

    I also had issues with the SLPLUS-PRO and the map not displaying after doing a version update. I tried everything that was suggested here in the forum without any success. But I did get my map to display after going to the store locator plus/general setting /Pro Pack module UN-checking "Force Load JavaScript". This worked for me, It may work for someone else.

  18. intlistsys
    Member
    Posted 1 year ago #

    I can confirm that the solution Websolo posted works to load the map without issues. However, when Force Load JavaScript is unchecked, the nearest address box is no longer displayed under the map.

  19. Websolo
    Member
    Posted 1 year ago #

    @intlistsys are your referring to the results entry below the map? If you are, it seems to be working fine on my end.

    optimushealthcare.org

  20. SAQIB SATTAR
    Member
    Posted 1 year ago #

    i have currently use store locator plugin now i want to upgrade this plugin and install store locator plus my question is that can i use previous API key for store locator plus

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic