WordPress.org

Ready to get started?Download WordPress

Forums

Store Locator Plus
failed to geocode, over query limit (26 posts)

  1. bradnpx
    Member
    Posted 1 year ago #

    I'm getting a 'failed to geocode: OVER_QUERY_LIMIT". I have turned on google Maps API v2 and v3, tried each one seperately, and added my site to the list of referrers. Nothing works. Additionally, if this bug is persistent, then you really should give the customers of your free version the ability to add the geolocation themselves. This is a great plugin that I otherwise can't use.

    http://wordpress.org/extend/plugins/store-locator-le/

  2. Cyber Sprocket Labs
    Member
    Posted 1 year ago #

    Turn off API V2.

    Set your retry limit in our main settings page to 3.

  3. trouble
    Member
    Posted 1 year ago #

    I got the same error today. I was able to add 2address last week. But today its not letting me add new address.

    This error "Address 2815A Main Street , Dallas, Texas 75226 failed to geocode. Received status OVER_QUERY_LIMIT."

    Look at the image.
    http://s17.postimage.org/l6yboyye7/img.jpg

    Please let me know how to fix this issue.

    Thank you!

    [ Please do not bump, that's not permitted here. ]

  4. chiprender
    Member
    Posted 1 year ago #

    Hello. I've been using this plugin successfully for several weeks....until today. I've successfully bulk-uploaded a CSV file with around 1000 locations. I successfully did this a few weeks back...and even did it successfully today 3 times...now alI I am getting is this "over query limit error" on both bulk upload, AND on adding single entries. I've generated a new API key...and even "enabled billing" to allow for 250,000 queries. I go to quotas...and it is sitting at 0% used...it's like it isn't even trying. Thoughts?

    Thank you in advance...I really do like the plugin! :)

    chip

  5. bradnpx
    Member
    Posted 1 year ago #

    @cybersprocket,

    I did try disabling API v2. It worked for a few days but then stopped suddenly with the same error as before.

  6. InSightskiing
    Member
    Posted 1 year ago #

    Also having this problem - when I add a new location it is not populating the latitude or longitude fields, and presenting me with the error - failed to geocode. Received status OVER_QUERY_LIMIT.

    I have increased the retries limit to 3, and don't believe I have API v2 turned on (could someone explain how I check this?)

    Please help!

  7. Cyber Sprocket Labs
    Member
    Posted 1 year ago #

    @InSightskiin - You need to log into your Google API console and check your settings. There is info in our Wiki (http://redmine.cybersprocket.com) on how to set your Google API for V3. V2 is in the same place.

    @bradnpx - Obviously something changed if it worked for a few days. What else did you change on the site? Or at Google? If you changed something as simple as the host name, base URL, or something similar that puts your domain out of sync with what you registered at Google you can have issues like this.

  8. don schilling
    Member
    Posted 1 year ago #

    I agree something must have happened with how Storelocatorplus interacts with GoogleAPI v3. I have been using this product without issues for several months and just in the past two weeks something changed and now I cannot add records.
    Earlier in this month I was uploading several hundred records per day and on some days had issues and got overlimit error on other days I did not. When this first occurred it was not an issue, I would just come back a few hours later, selected the un-coded records and re-code without issues.
    Then it seemed to change and about two weeks ago it hit the wall and now 100% of the time I get the overlimit error. If I try to recode a single record I get overlimit. If I try to recode a group of records I get overlimt. Each morning I try the same requests and get the same overlimit error.
    I think StoreLocatorPlus is a great product that fits my needs perfectly but I am frustrated that a change occurred in the past few weeks which hobbled the ability to add records.
    I have gone to google and obtained a fresh API number and am running version 3. Still get error. I have also changed retry limit and no help their either.

    Is there some type of monthly limit in addition to the daily limit? Do I just need to wait two more weeks and Google API will let me back in? I am quite confident I never breach 2,500 per day so am not sure how I could have triggered the goolge limit on my own.

    I really appreciate any advice and help so I can get this otherwise great plugin working again.

  9. trouble
    Member
    Posted 1 year ago #


  10. trouble
    Member
    Posted 1 year ago #

  11. don schilling
    Member
    Posted 1 year ago #

    I also still have the same error message and am not able geo-code any additional records. I have tried resetting my API, running without and API number and still get same error. Really would appreciate some help getting this otherwise great plugin working. Thanks

  12. don schilling
    Member
    Posted 1 year ago #

    Still having issues with over limit. As a work around, is it possible to modify the CSV upload file format so we can upload our own Latitude and Longitude and avoid the google geo-code limit?

  13. Cyber Sprocket Labs
    Member
    Posted 1 year ago #

    The way that geocoding works has NOT changed in recent release.

    Google, however, has clamped down on their API calls and is now much more stringent on calls that go over limit. If you are having limit issues then you likely need to add your credit card info on the Google API system so you can make more requests, ESPECIALLY if you are using the "center map on users location" as that requires an API call every time someone visit the locations page.

    @trouble - we respond to forum posts about once/week. If you need a faster response we do have paid support options available.

  14. chiprender
    Member
    Posted 1 year ago #

    Thought I'd follow up... I waited 24 hours and found that my issue went away. I was banging the connection too hard I guess. Now she works like a charm! LOVE the plugin by the way! Thanks guys!

  15. chiprender
    Member
    Posted 1 year ago #

    @don I tried that, unfortunately it didn't get me anywhere...there isn't a channel to get those into the database...although I didn't try to access via something like phpMyAdmin.

  16. don schilling
    Member
    Posted 1 year ago #

    Appreciate the response. I have seen several other users mentioning how the over limit issue has become an issue in the past month and in every instance the records count has been well below the google limits suggesting there is no need to purchase capacity from google. I am not using the "center map" feature and am well below the limits, so I am not sure why the error limits have recently become and issue when one month ago they were not.

    I think this is a great product and really hope there is a way to find a work around. Really appreciate your help. Thanks

  17. bradnpx
    Member
    Posted 1 year ago #

    Nothing has changed on my site, and if it did it was not because anyone did anything. My site is still hidden from public use, so it can't be the number of calls. I've resorted to inserting them right into the MySQL database. I think the geolocation process needs more QA attention.

  18. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    @bradnpx -

    We run over 4,000 geocode lookups on every release in addition to a dozen smaller loads/unloads on a half-dozen sites.

    Since the current code appears to work correctly in all of our tests, changing code simply to guess as to what may be wrong in your specific instance is not a good approach to solving your specific issue.

    If you can provide enough details so we can reproduce the problem we can fix it. Also, try eliminating as many variables as possible on your end. Deactivate all other plugins, try a base theme like twenty ten, and see if SLP works with your data. The best way to do this is setup a staging site with a clean WP install, install SLP, then load your locations.

  19. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    Geocoding updates are coming in 3.2:
    http://www.charlestonsw.com/wp-admin/post.php?post=5032&action=edit

    Short version - some servers have unpatched curl extensions which wreak havoc on various web request like JSON data coming back from Google.

    We are in final testing of 3.2 for release this week.

  20. undah
    Member
    Posted 1 year ago #

    I am having the same error and I only have added 1 location. I don't have an API set. So why is there an overload? I also made it retry 3 times and it didn't work.

  21. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    @undah - Are you on a shared host? If so you may need to get an API key so Google does not group your site with every site on the shared host when calculating your quotas.

  22. jasoncarrigan
    Member
    Posted 1 year ago #

    I have my locations already geocoded, is there a way to bulk upload and skip the geocoding, just insert the geocodes I have in my spreadsheet?

  23. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    Not in bulk - with Pro Pack you can manually enter them on a per-location basis. If I can get through my task list a better bulk import is on the list.

    BTW, more details on "OVER_QUERY_LIMIT" can be found here:
    https://developers.google.com/maps/documentation/business/articles/usage_limits

    You can try setting # of retries under "General Settings".

  24. jasoncarrigan
    Member
    Posted 1 year ago #

    I do have Pro-Pack, so I am using the bulk uploader...I actually bought all the products. Solved TONS of problems for me

    The feature request I suggest is:

    1. Select bulk upload
    2. Checkbox for "Use Google to Geocode my locations (Default - 2500/day limit)"
    3. Checkbox for "My locations are already Geocoded, use the data in my CSV file"
    4. Checkbox for "Skip geocoding, I will handle it later, just upload locations"

    In the csv file, you can add two columns at the end for geocode placeholders.

    You probably already thought of a good way to handle something like that, but I thought I would pass my thoughts along.

  25. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    @JC - yup, an enhancement to bulk upload with geocode data is on "The list".

  26. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    Here is a lot more info on recent updates related to this issue:
    http://wordpress.org/support/topic/over-query-limit?replies=1#post-3670484

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.