WordPress.org

Ready to get started?Download WordPress

Forums

Google Doc Embedder
Where do I put the code itself? (6 posts)

  1. DeborahRutter
    Member
    Posted 3 years ago #

    The code below...where does that actually, uh, go?

    Am I putting this into the body of my post? The pdf's I want to includes are all in my media files in WP, but I haven't been able to see anything on my site, so I am wondering if I am doing this completely wrong...

    Still green...Thank you!

    [gview file="http://full-path.to/file.pdf"]

    http://wordpress.org/extend/plugins/google-document-embedder/

  2. k3davis
    Member
    Plugin Author

    Posted 3 years ago #

    Yes, put it in the body of your post or page.

    Replace http://full-path.to/file.pdf with the actual, full URL of the file you're embedding.

    If nothing appears still, view the source and search for "gde" to see if any errors are displayed there.

  3. poetryisgood
    Member
    Posted 3 years ago #

    I just took over a WP Website and the Google Doc Embedder Plugin wasn't working. I found two inconsistencies and changed both, I'm not sure which one fixed the problem but its working now.

    1. The default plugin height and width settings were different from the settings specified in the code snippet (I removed the settings from the snippet):

    [gview file="http://full-path.to/file.pdf" height="400" width="400"]

    [gview file="http://full-path.to/file.pdf"]

    2. Changed the default setting in the plugin from "Enhanced" to "Standard"

    Enhanced Viewer
    Use this option to improve IE compatibility and enable toolbar customization.

    Google Standard Viewer
    Use this option if you experience problems with the Enhanced Viewer.

  4. k3davis
    Member
    Plugin Author

    Posted 3 years ago #

    Not sure what you're saying here exactly... the height and width attributes are optional, and left unspecified it will use the dimensions set in GDE Settings. The default viewer as of the most recent version is the standard viewer. Of course, existing settings are maintained when upgrading.

  5. poetryisgood
    Member
    Posted 3 years ago #

    Good point, I'm new to WP, I changed two things and one of the two fixed the problem. Going from Enhanced Viewer Google Standard Viewer must have done the trick.

  6. poetryisgood
    Member
    Posted 3 years ago #

    Going from Enhanced Viewer Google to Standard Viewer must have done the trick.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic