WordPress.org

Ready to get started?Download WordPress

Forums

Google Doc Embedder
[resolved] "Unable to find documnet" error (10 posts)

  1. Lea Cohen
    Member
    Posted 1 year ago #

    We've been using your plugin very successfully for that past 6 months, but suddenly today we started getting the above message for all of our docs.

    For example, this url returns that error:
    http://docs.google.com/a/clickit.ort.org.il/viewer?url=http://www.nanochannels.eu/wp-content/uploads/gravity_forms/4/2012/05/nanoproizvodi-Karmen-martinic.doc&hl=en_US&embedded=true

    But the doc exists - you can try yourself.

    What could be the cause of the error?

  2. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    I get a DNS error that the server "www.nanochannels.eu" can't be found. So that's about as far as I can go.

    Probably not the issue, but you don't want to use your Google Apps URL - I'm assuming that's only showing because you copied the URL of the failure page and you're logged in to your Google Apps account.

  3. mlautens
    Member
    Posted 1 year ago #

    I have also had the 404 errors crop up suddenly. 2.4.3 worked fine, I upgraded to 2.4.4 and where GDE used to display a file, now there was nothing. Blank screen, nothing.

    So I dumped the source code for the page and where GDE was called I saw an error about "404 document not found, use force='1' to skip this check." So I went back to the page and added that parameter. Now GDE displays...but just with a big 404 error and it looks like it's trying to reload the website in that window

    Here is a link to a page where the force parameter is used:
    http://riovistachurch.com/parentlink-newsletter-june-2012/

    Here is a link to a page where the force parameter is NOT used:
    http://riovistachurch.com/parentlink-newsletter-may-2012/

    In both cases, I have determined that the PDF being displayed exists at the URL specified. I can copy and paste it into a browser tab and it displays fine.

    I hope this is helpful. By the way, I have NEVER been able to used the Enhanced Viewer option without getting the 404 errors.

  4. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    mlautens,

    I've been looking into this and while I agree that the 2.4.4 upgrade caused the problem (since that's when it broke) I'm having trouble reproducing the issue with my own documents, or even with your own using my site. I would really benefit from you submitting a support request via the support link in your plugin list that will allow me to reproduce the situation as closely as possible (WP version, exact shortcode you're using, your current settings). Would you be willing to help me with this?

    Kevin

  5. mlautens
    Member
    Posted 1 year ago #

    Yep. I'm going to do that right now.

  6. mlautens
    Member
    Posted 1 year ago #

    For us, at least, the 2.4.5-beta version fixed the problem.

  7. Lea Cohen
    Member
    Posted 1 year ago #

    I don't understand why you're getting a DNS error. Are you able to go to it with the browser? http://www.nanochannels.eu

    And you right about the Google Apps URL not being the correct one. This is the correct URL: http://docs.google.com/viewer?url=http%3A%2F%2Fwww.nanochannels.eu%2Fwp-content%2Fuploads%2Fgravity_forms%2F4%2F2012%2F05%2Fnanoproizvodi-Karmen-martinic.doc&hl=en_US&embedded=true

  8. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Leac, no, I am not able to go to that address. Internet Explorer "cannot display the web page" and Firefox reports "Server Not Found".

    Perhaps the problem is with my ISP if the site is still running. In that case, do you have a chance to test beta 4 to see if it resolves the issue for you?

    http://www.davistribe.org/gde/beta-program/

    The other possibility is that whatever issue blocks me from visiting the site is also affecting Google, which would make the plugin ineffective as well.

    Thanks,

    Kevin

  9. Lea Cohen
    Member
    Posted 1 year ago #

    Hi Kevin,

    Thank you for your answer. The fact that you can't reach the web page is quite worrying. I would like to check that path before I try the new beta.

  10. Lea Cohen
    Member
    Posted 1 year ago #

    Hi Kevin,

    I checked into it, and it actually was a DNS problem. We fixed it, and now the plugin works fine! Thank you for giving me the correct direction.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.