WordPress.org

Ready to get started?Download WordPress

Forums

Google Doc Embedder
[resolved] PDF not displaying with IE9 (12 posts)

  1. MrBillie
    Member
    Posted 1 year ago #

    Hi! Hello everybody!

    Great plugin, worked fine for some time.

    Now i can't see the pdf with Internet Explorer 9 but works ok with Google Chrome.
    With IE, if i choose "Google Standard Viewer", it makes a blank space for the pdf archive, but it doesn't appear ("Internet Explorer can not show the web page").
    With "Enhanced Viewer" is better, i can see "loading" till the end, but after all the pdf doesn't show.
    With Google Chrome it's ok with both optiones.
    I'll give you the link ( http://espacioaudiologico.com.ar/ambito-de-practica-en-audiologia/ ), now with "Enhanced Viewer" on.
    If you need to switch the viwer selection, please let me know.

    Thanks in advance and sorry for my bad english!

    See you!

    http://wordpress.org/extend/plugins/google-document-embedder/

  2. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    I tested the link you gave in the lastest versions of IE, Firefox, and Chrome for Windows 7 and found all displayed the PDF as expected.

    Please completely clear your browser cache using this method and see if your issue is resolved. If not, it may be a network delay or another local issue that is not affecting the internet at large.

  3. MrBillie
    Member
    Posted 1 year ago #

    Thanks for the answer!
    You're right. I didn't clear the cache browser, but now the file looks ok... maybe was the network delay you said or something.
    Anyway, thanks again for your fast answer and for this excellent tool!

    Billie

  4. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    No problem, I'm glad that solved it.

  5. contact@peterbennett.net
    Member
    Posted 1 year ago #

    Hi, I just dug this call up when looking for resolutions to my problem. The example in this call... http://espacioaudiologico.com.ar/ambito-de-practica-en-audiologia/
    ...is not working for me in IE9. I get 'Internet Explorer cannot display the webpage' Same for my example at http://root.peterbennett.net/wordpress8/test2
    It's fine in Chrome etc. Something of a show-stopper, please let me know if any resolution found or if it's just me ;o)

  6. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Both documents load normally for me in IE9 on the first try.

    Have you followed the same advice as above (clear your browser cache)? Remember that in IE it doesn't clear cache on favorited sites by default.

    Let me know if you need more help.

    Kevin

  7. contact@peterbennett.net
    Member
    Posted 1 year ago #

    Hi Kevin,
    Mucho thanks for the ol' swift response. I've gone back through the clear cache process and still get the same 'cannot display' message. By the way, I get the same result from IE10 on different Win8 consumer preview pc.
    Peter

  8. contact@peterbennett.net
    Member
    Posted 1 year ago #

    ...ah, update, on a client site I changed the file= link from loading the pdf from the clients domain to the same pdf on my domain and it works, ok, looking into it further...

  9. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Peter,

    Sorry for this inconvenience, but changing the link also is an indicator that the browser is hanging on to something it shouldn't. The viewer works the same with both locally and remotely hosted files - it doesn't differentiate at all.

    Sometimes switching from Standard Viewer to Enhanced in GDE Settings, reloading, and (optionally) switching back again can also trigger a reload without cache.

    These (IE9) steps also help ensure cache is not in play, though there will probably be performance and network hit if you leave them like this on an ongoing basis:

    Select Tools >> Internet Options.
    Click the Settings button in Browsing History.
    Select the Every time I visit the webpage radio button.
    Click OK to close the Settings dialog.
    Click OK to close the Internet Options dialog.

    Let me know how it fares for you. (Of note: I've yet to try this plugin, or anything else for that matter, in IE10.)

  10. contact@peterbennett.net
    Member
    Posted 1 year ago #

    Thanks Kevin.
    The browser setting change didn't help. What was working for me yesterday isn't working now - for the context I was planning to use it, it needs to be rocksteady, work in IE and there's no chance of the visitors modding their browser settings anyway, so I'm kind of backing out.
    Best,
    P

  11. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    No javascript application is going to be 100% available in every browser, especially when you're dealing with junk like IE; but that said, I've not had any problem loading the above linked documents in any browser on any computer I've tried. I'm sorry for whatever difficulty you've experienced. Hope you find another solution for your requirement.

  12. contact@peterbennett.net
    Member
    Posted 1 year ago #

    Kudos to you, I think you're pretty much at the cutting edge with your plugin, there doesn't seem to be an alternative! I'm using a link to open a new tab on Google docs. I came across a paid service which purports to do the embed thing but that's (as a WP plugin, anyway).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic