WordPress.org

Ready to get started?Download WordPress

Forums

Google Doc Embedder
[resolved] Mask URL (14 posts)

  1. mrhaanraadts
    Member
    Posted 2 years ago #

    I get an error when using the mask url setting
    400 - Bad Request

    http://wordpress.org/extend/plugins/google-document-embedder/

  2. mrhaanraadts
    Member
    Posted 2 years ago #

  3. mrhaanraadts
    Member
    Posted 2 years ago #

    I just installed the beta version, but the same problem occurs.

  4. k3davis
    Member
    Plugin Author

    Posted 2 years ago #

    mrhaanraadtsm,

    I have been able to reproduce this error when using filenames that contain spaces. Can you confirm this?

    Filenames with spaces is related to the bug I'm trying to solve in 2.4.5. I wish people wouldn't use them, because they are nonstandard, but I realize they aren't going away so I will continue to try to make them work. Try again with 2.4.5 beta 2 if you don't mind...

    If your filename does NOT contain a space then let me know as there may be another issue I'm missing.

    Thanks,

    Kevin

  5. mrhaanraadts
    Member
    Posted 2 years ago #

    Kevin,

    The filename contains spaces, so that could be the problem.
    I'm glad to here that you are trying to solve it.

    Thanks,
    Thijs

  6. k3davis
    Member
    Plugin Author

    Posted 2 years ago #

    If you had a chance to test beta 2 of 2.4.5, does it fix this issue for you?

  7. mrhaanraadts
    Member
    Posted 2 years ago #

    I add another line to the code:
    $file = str_replace(" ","%20",$file);
    so that problem is solved.

    I still have another problem. The force download doesn't work. It still opens the PDF in my browser. My objective is a link that is not visible and forces download.

    The most important thing is that the link is not followed by search engines. So my questions is, is there a nofollow tag in de plugin?

    Thanks

  8. k3davis
    Member
    Plugin Author

    Posted 2 years ago #

    Please try again with beta 3. I believe the force download option is fixed.

    The value of nofollow is extremely debatable (see this) but you're right, if you're masking the URL then you probably want to reduce as much search engine traffic on it as possible. So I have added that as well, only to the Mask URL option.

    Thanks for reporting these issues. Let me know if they are all resolved yet or not.

    Kevin

  9. mrhaanraadts
    Member
    Posted 2 years ago #

    With the new beta version, the download is forced. So that works, but when i select the force download (mask url) setting, i get the same 400 error as before.
    So there has to be a problem with the difference between the normal force download and the force download with the mask url setting.

    You're very close. I'll keep looking for the problem.

    Many thanks for the effort so far.

  10. mrhaanraadts
    Member
    Posted 2 years ago #

    And the pdf file i download is empty

  11. k3davis
    Member
    Plugin Author

    Posted 2 years ago #

    I know the problem with the empty PDF and will fix that in the next build (a little overzealous removing debug code, oops) but I can't reproduce the 400 error anymore in beta 3, even for filenames containing spaces. Could you send me a URL of a document causing the problem using the support form from your plugin list? Maybe there's another type of filename I'm not testing for. That would be helpful.

  12. mrhaanraadts
    Member
    Posted 2 years ago #

    I found the problem. It was a very stupid mistake. I saved the beta version with a space in the name.
    So mystery solved.

    Everything works, except the empty PDF.

  13. k3davis
    Member
    Plugin Author

    Posted 2 years ago #

    Beta 4 should address this issue. If nothing else crops up this will be the released version.

  14. mrhaanraadts
    Member
    Posted 2 years ago #

    I just installed beta 4 and it works!

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.