WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Google Doc Embedder] embedder not working (9 posts)

  1. poly-e
    Member
    Posted 4 years ago #

    hi, i've installed google doc embedder plugin on my wp site and it doesnt work at all!
    already configured gde settings, everything seems normal, but it just doesnt work
    iḿ trying to make a pdf available on a post and it just shows the code,
    whats the matter?
    thanks

  2. k3davis
    Member
    Posted 4 years ago #

    poly-e,

    I've definitely received no other reports like this; you will have to send me more information for me to be able to help. You can do so here or through the support page.

    *What version of GDE is installed and activated?
    *What is the URL of the file you're trying to embed?
    *What is the shortcode you're using in your post?

    This would be the first step in solving your problem. Thanks.

  3. heleskhi1
    Member
    Posted 4 years ago #

    hi there, i'm new to wordpress and trying to get the google doc embedder to work but unfortunately without success. the url string keeps appearing on the page instead of the plugin. i'm using gde 1.9.4. and the gde settings are at default when i look at the source i get the following error message <!-- GDE EMBED ERROR: file attribute not found (check syntax) -->. I'm really stuck and not sure what to do. the url file i'm trying to embed is [gview file="http://robertsmithpambula.com.au/new/wp-content/uploads/2010/07/FURN0517.pdf"]
    i tried emailing you at the support page...but i think there may be a problem with the submit button? any help would be fantastic.

  4. k3davis
    Member
    Posted 4 years ago #

    Hi heleskhi1,

    When I try to embed that URL, I also get an error but it's different than yours (a file retrieve error with no status code). You can add force="1" to the shortcode to bypass the internal error checking and the file will load. However it doesn't return the file size. I wonder if there is something nonstandard about the http server on which the file is being hosted.

    Let me know if you need more help. Thanks for reporting an issue with the form on my support page - I'll take a look at that as well!

    Kevin

  5. cburell
    Member
    Posted 3 years ago #

    Update: I spoke too soon. See post below this one for more.

    I just had both glitches reported in recent threads with version 1.9.5 -- first, syntax error msg, then "Google account login required" -- and doinked with settings until it worked.

    My current settings on my WP dashboard are now:

    Viewer Options:

    • enhanced viewer
    • default width: changed to "400 px" (my preference)
    • default height: 500 px (my pref, again)
    • Everything else unchecked.

    Download Link Options:

    • "Display the download link by default" is checked
    • Everything else unchecked

    Advanced Options: all unchecked.

    In the post that wasn't working, I stripped all shortcode except [gview file="name.pdf"] -- no width, height, force, etc.

    It all works now, even when I'm not logged in to Google. I'm on a Mac using FF, if that matters, and my pdf's are hosted on my web host.

    Hope that helps someone :)

  6. cburell
    Member
    Posted 3 years ago #

    OOPS. Spoke too soon. Got this message with those settings:

    Warning: array_key_exists() [function.array-key-exists]: The first argument should be either a string or an integer in /nfs/c01/h09/mnt/32929/domains/beyond-school.org/html/wp-content/plugins/wp-footnotes/footnotes.php on line 167
    
    Warning: Cannot modify header information - headers already sent by (output started at /nfs/c01/h09/mnt/32929/domains/beyond-school.org/html/wp-content/plugins/wp-footnotes/footnotes.php:167) in /nfs/c01/h09/mnt/32929/domains/beyond-school.org/html/wp-includes/pluggable.php on line 890

    So the edit on the post won't save now, but the post itself seems to somehow be working. [/headscratch]

  7. k3davis
    Member
    Posted 3 years ago #

    Since that error relates to the plugin wp-footnotes, maybe there is some kind of conflict going on. Can you try (temporarily) to deactivate that plugin and compare your results?

  8. kevin2i
    Member
    Posted 3 years ago #

    wordpress 3.0
    gde 1.9.5 and beta 1.9.6

    Plugin not working without the short code -
    [gview file="http://secondimagethriftstores.com/frf/wp-content/uploads/test.pdf" force=1]

    The PPT PDF viewer plugin does not work either, so perhaps it a problem with the implementation of google docs viewer.

    ALSO - and this is a complaint I have with many plugins - why are the 'shortcode' rules difficult to locate? Why can't the instructions on shortcode usage be included on the settings page? With multiple plugins installed, I can't remember all the shortcodes I need, and it is time consuming and annoying to search for basic instructions. Part of this is a wordpress issue - it is silly to have every plugin list the (identical) installation instructions, but not have a consistent place to find usage instructions.

    A quick line or two on the settings page would be helpful!

  9. k3davis
    Member
    Posted 3 years ago #

    kevin2i,

    Thanks for your sharing your opinions and reporting the problem. I'm not sure what problem you're really having. The shortcode as you have it above works fine on my server. I do not even need to include the force=1, it works normally with just the file attribute. If you are receiving some error, please report that and I can take a closer look.

    As for your documentation complaint, the basic syntax on the plugin info page where you download the plugin is sufficient for this use. A link is provided there to extensive documentation for all of the available attributes, whether they are required or not, as well as a detailed description of all available settings and how to override some of them individually when needed. This link is also on the plugins page (the link to the plugin website) and the question mark icons in each section of the settings pages takes you directly to the relevant documentation. I've done my best to outdo other plugin developers in this area.

    What you're probably really asking for is a way to upload or select a file and have the shortcode generated for you, so you don't have to remember or look up the syntax at all. Indeed many have asked for this, and I agree this is the best solution, but it requires more time than I as a full time student can offer it at this point. I do my best to make incremental improvements and spend a lot of time providing support for a free plugin. I wish I could do more but I'm merely human; feel free to offer your own improvements, the code is open source after all and I'd be happy to add you as a contributor to the project if you want to help. :)

    Kevin

Topic Closed

This topic has been closed to new replies.

About this Topic