WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Google Doc Embedder] Any idea why this isnt working for me? (11 posts)

  1. theshae
    Member
    Posted 4 years ago #

    This is what I have:

    [gview file="http://www.flabota.org/wp-content/uploads/2009-Cashiers-Schedule-and-Signup.pdf"]

    This is the error:

    <!-- GDE EMBED ERROR: invalid URL, please use fully qualified URL -->

    This link works fine. Any ideas why this is happening?

    http://wordpress.org/extend/plugins/google-document-embedder/

  2. k3davis
    Member
    Posted 4 years ago #

    theshae,

    I pasted the code just as you have it, and it is working fine on my server (using 1.7.3 of the plugin):

    http://davismetro.com/gde/test/

    If the problem persists for you, we'll have to look at the issue deeper with more specific information about your server setup. Let me know and I'll help if I can.

  3. theshae
    Member
    Posted 4 years ago #

    Hmmm, I tried it on another install of wordpress on the same server and didnt work there either.

    Any idea where i should start looking?

  4. k3davis
    Member
    Posted 4 years ago #

    hi theshae,

    I'm not sure what on an individual server would cause this particular error (link fails to validate). Is your plug-in version 1.7.3, and your WordPress version 2.8.4? Also, what version of PHP does the server run? If you don't want to share this information publicly, you can submit the support form on the plugin site, or email me directly from the email address at the top of the GPL statement in gviewer.php.

    Thanks.

  5. k3davis
    Member
    Posted 4 years ago #

    I have a theory about this that may or may not be so - if you're willing to test for me (since I can't reproduce this), send me your email address using the contact info above and I'll send you a test version of the plugin you can try.

  6. theshae
    Member
    Posted 4 years ago #

    email sent. thanks for your help

  7. k3davis
    Member
    Posted 4 years ago #

    theshae, I didn't get your message, but you may want to try the test version for 1.8 to see if it addresses your issue. I've posted information about it here. If you continue to get the error, starting with this version (1.8) you can choose to bypass the plugin error checking by adding to the shortcode force=1. Any errors at that point would be handled by the viewer itself.

    Let me know what you find out.

  8. theshae
    Member
    Posted 4 years ago #

    Hello, I tried to download v 1.8 but it said it was not available. Would you mind re-uploading it?

  9. k3davis
    Member
    Posted 4 years ago #

    This update has been generally released and can be downloaded from the plugin page. Thanks.

  10. theshae
    Member
    Posted 4 years ago #

    Ok, sorry didn't realize it was public. Its working now.

    Does it allways prompt you to log into a google account before you can view the document?

  11. k3davis
    Member
    Posted 4 years ago #

    Probably. The viewer is meant to display documents that are public only, so if you save it somewhere outside of Google Docs, no login would be required. More information about this is in the FAQ, or let me know if you need clarification.

    Thanks for letting me know your problem was resolved!

Topic Closed

This topic has been closed to new replies.

About this Topic