WordPress.org

Ready to get started?Download WordPress

Forums

Google Custom Search
[resolved] In 3.4, causes script problems in the WP Control Panel (8 posts)

  1. ForSpareParts
    Member
    Posted 2 years ago #

    In WP 3.4, if I visit many pages on the WP backend with GCS enabled, I get a script error and a bunch of the Javascript for the page doesn't load. It breaks (at least) mouseover menus and the expandable widget menus.

    http://wordpress.org/extend/plugins/google-custom-search/

  2. DNBrawler
    Member
    Posted 2 years ago #

    Yes. I just deactivated it, was a good plugin :L

  3. Dirty Bill
    Member
    Posted 2 years ago #

    Same issue.

  4. anychanh
    Member
    Posted 2 years ago #

    Same issue, just disabled it.
    Pls fix it :(

  5. SueJ1
    Member
    Posted 2 years ago #

    Also deactivated here ... hopefully there will be an update soon to fix the issue! It's a good plugin. Broken in WP 3.4, though was working fine before.

    It didn't spit out error messages on my site - just made some other plugins (eg WP Jump Menu) inoperable and broke drag and drop options for other admin areas - theme and plugin options pages etc.

  6. Jazzvox
    Member
    Posted 2 years ago #

    Same issue, just disabled it. After update to WP 3.4 (PHP 5.3) - Firebug console:
    $("#dialog").dialog is not a function
    .../wp-content/plugins/google-custom-search/js/gsc.js?ver=3.4 Line 1

    It's a widespread topic in the forum, with many "possible answers":
    http://wordpress.org/support/topic/lost-functionality-of-admin-menus-in-331
    http://wordpress.org/support/topic/wordpress-widgets-not-working-correctly-menus-not-opening-possible-answer
    http://wordpress.org/support/topic/admin-panel-not-working-properly
    ...

  7. edwinkwan
    Member
    Plugin Author

    Posted 2 years ago #

    Hi guys,

    Sorry for the late response. Been away on holidays and just got back.
    Thanks for the feedback from everyone regarding the plugin issue with wordpress 3.4. It seems like it is a common issue with many other plugins which uses JQuery.

    Anyways the fix has been released in version 1.3.4

    Thanks once again for the feedback.

    Edwin

  8. Jazzvox
    Member
    Posted 2 years ago #

    Life is good again, thanks Edwin for the fast realization! And it's free ;-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic