WordPress.org

Ready to get started?Download WordPress

Forums

Google+ Crossposting
Manual mass import? (9 posts)

  1. lcocking
    Member
    Posted 2 years ago #

    I just installed your plug-in. So far everything seems to be working. But when I clicked on the "manual mass import" button, it imported just one post, which I put in G+ in early August. Any idea why it skipped all the more recent ones?

    Also, a feature request: it would be great to be able to import from multiple G+ accounts (my husband and I share a blog). :) But thanks - great plugin!

    http://wordpress.org/extend/plugins/g-crossposting/

  2. Sebastian
    Member
    Plugin Author

    Posted 2 years ago #

    duplicate post, please ignore...

  3. Sebastian
    Member
    Plugin Author

    Posted 2 years ago #

    Hhhm, you probably had the setting of maximum posts to import set to 1. Therefore, the manual import only gets the latest post and imports it.

    If you now change the number to 100 (which is the current maximum), it won't import the other posts, because it always just imports posts, which are newer than the one imported last.

    To overcome this problem, you need direct access to the database, because there it stores the ID of the post imported last. If you want to try it, go as follows:

    1. Set the number of posts to import to 100 and save your settings.
    2. Delete the single post, which was already imported using the WordPress admin interface.
    3. Open your database web front end (I hope your hosting provider is having something like that, e.g. PHPMyAdmin)
    4. Make a database backup.
    5. Locate the "options" table of your WordPress installation. Please note, you might have a suffix added to the table name, so check your WordPress database settings, too!
    6. Run the following SQL statement. Please note, you might have to adapt the name of the options table in case you are using a suffix. Also, the table name (options) must be enclosed with backticks. I can't add them here, because the forum editor removes them... SELECT * FROM options where option_name = 'g_crossposting_last_activity_id'
    7. This SQL statement should have returned a single row. There should be a way in your front end to delete this row.
    8. After you deleted the row, you can start the manual import again.

    I hope this gives you an idea how to accomplish that.

  4. lcocking
    Member
    Posted 2 years ago #

    I think I'm not going to mess with the database. My G+ posts aren't that significant. :) But just FYI, it didn't pull the most recent post. It skipped over at least 10, including one from less than an hour before, and instead took one from August 11. I have been experimenting with various Firefox add-ons for G+, so maybe that had something to do with it. They're all disabled now.

  5. JeffHicks
    Member
    Posted 2 years ago #

    I am having the same problem on my hosted WordPress blog. When I do a mass import I get a single entry from July. I tried the database trick, more than once, and no change. I am running the latest plugin and WordPress versions.

    I also had the ForEach problem and manually edited the config file so now it runs but nothing gets cross posted. How often does it check anyway for new posts? I can live without old posts but I have yet to see anything new show up.

    Any suggestions?

  6. lcocking
    Member
    Posted 2 years ago #

    I figured out my problem - user error. My posts weren't public so they didn't get picked up.

  7. JeffHicks
    Member
    Posted 2 years ago #

    That makes sense. I'm getting used to G+. I'll try this out.

  8. JeffHicks
    Member
    Posted 2 years ago #

    Yep. Creating a public post worked just fine. Something else that should go in the documentation for FAQ.

  9. Sebastian
    Member
    Plugin Author

    Posted 2 years ago #

    The plugin checks G+ about every 5 minutes. However, if you don't have a visitor on your site for more than five minutes, it will only the next time someone visits your page. This can only be circumvented by having a cron job on your site to run every 5 minutes. However, cron jobs are usually not available on cheap free hosting offerings.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic