WordPress.org

Ready to get started?Download WordPress

Forums

Google Analytics by Yoast
[Plugin: Google Analytics for WordPress] Had to disable. Breaking my slideshow (11 posts)

  1. dameonjamie
    Member
    Posted 2 years ago #

    I had to disable this plugin . It is preventing a slideshow from running:

    http://www.travelandwildlifeaustralia.com/

    This is the first time I have had this problem. GA for WP works with the slideshow on another website I built:

    http://www.travelandwildlifephotography.com/

    Any ideas why?

    Cheers,
    Dameon

    http://wordpress.org/extend/plugins/google-analytics-for-wordpress/

  2. Dalton
    Member
    Posted 2 years ago #

    Yes, I have confirmed that this plugin completely kills the Portfolio Slideshow plugin. It's just a custom query and a loop of attached images, what gives?

  3. aljuk
    Member
    Posted 2 years ago #

    Oh no, I hope there's an easy fix. GA for WP is essential to me, and Portfolio Slideshow is integral to a newly launched client site of mine, but the old version of the plugin loads the images WAY too slow, hence the need for the update.

    @ Dalton - obv the loop should be irrelevant - I'm guessing a clash in the js of the two plugins?

  4. Dalton
    Member
    Posted 2 years ago #

    It's not a javascript issue - the Google Analytics plugin actually kills the loop and the slideshow does not return any images. And it only seems to do it on certain server setups. Still not sure why...

    Good news, Portfolio Slideshow 1.3 is much faster than the previous version! If you still have performance issues I can give you a quick tip to speed things up, too.

  5. Dalton
    Member
    Posted 2 years ago #

    Hey Dameon,
    I've now tried just about every combination of Google Analytics for WordPress setting along with every combination of Portfolio Slideshow setting and cannot get the problem to appear on my server. But I've had three users report it, so it's definitely an issue under some circumstances.

    Would you mind sending me a PM via my forum with your site login information for the WP installation you're having trouble with?

    If it's a live site and you've already worked around it, never mind. Just send me a heads up the next time it comes up so I can take a look and try to figure it out.

    Dalton

  6. dameonjamie
    Member
    Posted 2 years ago #

    Hi Dalton,

    Sure thing. I'll send it now. Thanks!

    Dameon

  7. aljuk
    Member
    Posted 2 years ago #

    I've updated to the new version, have Google Analytics for WP running, and am not experiencing any issues. Site and slideshow are working fine, and Analytics is tracking as normal.

    Dalton, performance is good now, but any extra speed tips gratefully received! :)

  8. dameonjamie
    Member
    Posted 2 years ago #

    It's every WordPress installation for me now. I have found:

    If I install Google Analytics for WordPress, and activate it is DOES NOT yet interfere with Portfolio Slideshow Pro.

    It's when I insert the Google Analytics tracking code into Google Analytics for WordPress that PSP stops working.

    Here is the latest site:
    http://www.amjphotocairns.com.au/

    I need an alternative to GA to WP.

  9. dameonjamie
    Member
    Posted 2 years ago #

    It's also killing "Add to Any".

  10. dameonjamie
    Member
    Posted 2 years ago #

    OK it seems that I can run the following combinations:

    GA for WP + Add to Any
    PSP + Add to Any

    And I cannot run the following combinations.

    But not GA for WP + PSP
    And not GA for WP + PSP + Add to Any

    Need help urgently.

  11. dameonjamie
    Member
    Posted 2 years ago #

    I am now using Google Analyticator. I am no longer having issues now that I have changed.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic