WordPress.org

Ready to get started?Download WordPress

Forums

Google Analytics for WordPress
Got an Error on multisite Network activated (10 posts)

  1. Mitch
    Member
    Posted 1 year ago #

    Got an Error on multisite Network activated
    Fatal error: Class 'GA_Admin' not found in /home/xxxxxx/public_html/wp-content/plugins/google-analytics-for-wordpress/googleanalytics.php on line 1583

    and on another add on blog I was getting the share info or something like that and each time I clicked no or yes it would say I do not have enough permissions

    http://wordpress.org/extend/plugins/google-analytics-for-wordpress/

  2. CliffAscent
    Member
    Posted 1 year ago #

    I'm seeing this same error message when creating a new subsite in a clients multisite installation. The only way to get the new subsite to work was to remove the plugin via FTP.

  3. matthewdavis1
    Member
    Posted 1 year ago #

    I hit this error on one of my multisites too. The way I fixed it was to visit the dashboard of the effected site. I don't think the Google Analytics plugin populates all the db entries for all the multisites at install.

  4. Mitch
    Member
    Posted 1 year ago #

    The way I fixed it since the author did not reply is to Delete it. Now there is no Problems. really Surprised at Joost, usually he has great Plugin support. Hopefully he will see this post and help you guys out for me I'm done with it could not wait any longer.

  5. new_B
    Member
    Posted 1 year ago #

    I am seeing this issue as well. Has there been any news besides removing the plugin?

  6. Spinal
    Member
    Posted 1 year ago #

    I can confirm that visiting the dashboard of the affected sites (and entering the Analytics code for each one) solves the problem.

  7. jakilevy
    Member
    Posted 1 year ago #

    @Spinal - thanks. That's a good work around, but not a solution to the issue.

    @Yoast or anyone else - any idea how we can avoid this error message while the plugin is "Network Activated" and no GA code is inserted?

  8. Mitch
    Member
    Posted 1 year ago #

    I didn't realize this was yoast's plug in I had another plugin that support was never answered on here looks like I'm going to delete this one also he a real busy guy

  9. turkeyphant
    Member
    Posted 1 year ago #

    Still no fix released for this problem?

  10. pwm2
    Member
    Posted 1 year ago #

    till there's an official fix, change this in googleanalytics.php:

    if ( !isset( $ga_admin ) )
        $ga_admin = new GA_Admin();
    $ga_admin->set_defaults();

    to this:

    if ( !isset($ga_admin) && class_exists('GA_Admin') )
        $ga_admin = new GA_Admin();
    if ($ga_admin) $ga_admin->set_defaults();

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic