WordPress.org

Ready to get started?Download WordPress

Forums

Google Analytics for WordPress
Custom Code: _setSiteSpeedSampleRate() (6 posts)

  1. wolfy_
    Member
    Posted 1 year ago #

    Hi,

    When I inser the Custom Code:
    _gaq.push(['_setSiteSpeedSampleRate', 100]);

    and the I save it change it for:
    _gaq.push([\'_setSiteSpeedSampleRate\', 100]);

    and this is breaking my analytics, is there any solucion?

    Thanks

    http://wordpress.org/extend/plugins/google-analytics-for-wordpress/

  2. nsgundy
    Member
    Posted 1 year ago #

    Hi,

    Just came across the same issue, some additional information:
    When adding
    _gaq.push(['_setSiteSpeedSampleRate', 100]);
    to the custom code section,
    _gaq.push([\'_setSiteSpeedSampleRate\', 100]);
    is stored in the database and this is reflected by looking at this option again after adding it for the first time. The result when loading the page however is
    _gaq.push(['_setSiteSpeedSampleRate', 100]);
    and that is working well.

    Now when you just hit save on the analytics settings page for the second time, the following will be stored in the database:
    _gaq.push([\\\'_setSiteSpeedSampleRate\\\', 100]);
    When loading the page again
    _gaq.push([\'_setSiteSpeedSampleRate\', 100]);
    will be the result and that's where the analytic code breaks and stops recording.

    So there seems to be an issue with escaping special characters when storing this value. The first time the ' will get escaped to \' and that just seems to be fine. But on a subsequent save both the escaping character as well as the original ones will be escaped again, resulting in the \\\' which breaks it. Assuming that each subsequent save will add a lot of backslashes.

    So current workaround is to remove any backslashes from the custom code setting whenever you are saving the settings.

  3. nsgundy
    Member
    Posted 1 year ago #

    Alright, found a fix for this.

    Looking at version 4.3.2 of Google Analytics for WordPress.
    Change line 561 in wp-content/plugins/google-analytics-for-wordpress/admin/class-admin.php from
    'content' => $this->textinput( 'customcode' ),
    to
    'content' => stripslashes($this->textinput( 'customcode' )),

    This adds the same function call for reading the customcode variable as used by the code that actually inserts the variable into the tracking code when building a page.

  4. nsgundy
    Member
    Posted 1 year ago #

    Can this please be implemented? The update to 4.3.3 did not include a fix.

  5. David Hunt
    Member
    Posted 1 year ago #

    I just found there are at least two other threads about this bug.

    I just tried this fix but it did not work for me, using version 4.3.3 of the plugin with WordPress 3.5.1. The custom code string is still truncated and contains backslashes.

    Joost, is there any chance a fix can be incorporated into the next update?

  6. Erik Hos
    Member
    Posted 1 year ago #

    Having the same problem when adding the custom code for pagespeed tracking. A fix would be appreciated, as I'd rather not modify the plugin files after each update.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.