WordPress.org

Ready to get started?Download WordPress

Forums

Google Analytics by Yoast
[Plugin: Google Analytics for WordPress] "Another site was requesting access to your Google Acc (6 posts)

  1. evanmcd
    Member
    Posted 3 years ago #

    When trying to authorize the plugin with GA, I get this error:

    "The page you have requested cannot be displayed. Another site was requesting access to your Google Account, but sent a malformed request. Please contact the site that you were trying to use when you received this message to inform them of the error. A detailed error message follows:

    The site "http://mysitedomain.com" has not been registered."

    (Of course mysitedomain.com is the real domain name of my site).

    The domain I'm using does use Google Apps, and I've heard others say that they've a problem with that. Their solution ( http://goo.gl/tmJ4Y ) was to 'register our domain with Google'. Unfortunately, I don't know what that would mean in this context.

    Thanks for any help folks can offer.

    http://wordpress.org/extend/plugins/google-analytics-for-wordpress/

  2. RavanH
    Member
    Posted 3 years ago #

    Same issue here... Both with Google Analytics for WordPress and Google Analyticator plugins. The funny thing is that authentication through Google Analytics Dashboard does work fine!

  3. RavanH
    Member
    Posted 3 years ago #

    Ah... found the link to "register the domain" : https://www.google.com/accounts/ManageDomains

    Adding the domain and completing the steps (although I have no idea what I'm doing) has worked. Now authentication works fine in Google Analytics for WordPress too.

    Wonder why Google Analytics Dashboard authentication worked fine all along without needing this obscure registration...

  4. evanmcd
    Member
    Posted 3 years ago #

    Great, thanks so much RavanH. I'm good to go now :)

  5. dpbklyn
    Member
    Posted 3 years ago #

    Hi and thank you in advance!

    I am having the same problem...I registered the domain, but when I get to the authsub step, I enter:

    http://mydomain.com and I get the error:

    AuthSub target path prefix does not match the provided "next" URL.

    I have no idea what I am doing wrong...

    Any help would be hugely appreciated!

    dp

  6. Harish Chouhan
    Member
    Posted 3 years ago #

    hello,
    The solution (involves more steps) is to add your domain in your Google account using this link https://www.google.com/accounts/ManageDomains

    Once you do that you will have to click a link "manage http://www.yourdomain.com" and in the "Target URL path prefix:" field enter the URL as:
    http://www.yourdomain.com/wp-admin/options-general.php?page=google-analyticator.php

    After its done, simply try authenticating again and it works.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic