WordPress.org

Ready to get started?Download WordPress

Forums

Google Analytics Dashboard
[resolved] User Rate Limit Exceeded - Please help. (30 posts)

  1. foodin65
    Member
    Posted 1 year ago #

    Hello,

    I'm using your plugin in 40+ of my clients sites. This morning, I started getting emails from al my clients stating that their analytics data is no longer available.

    I logged into all sites and I'm getting this message:
    Error gathering analytics data from Google: usageLimitsuserRateLimitExceededUnregUser Rate Limit Exceeded. Please sign uphttps://code.google.com/apis/console

    I have created a project for one of the websites with this problem inside the google api console, but there is no place in Google Analytics Dashboard to put the API Keys.

    How should I fix this issue?

    http://wordpress.org/extend/plugins/google-analytics-dashboard/

  2. tomaxite
    Member
    Posted 1 year ago #

    Hello,

    I have the same problem. Have you found a solution?

  3. foodin65
    Member
    Posted 1 year ago #

    @tomaxite - No I have not. Though I did take an extra step of adding the sites to Google Webmaster Central. This had no affect on the problem.

    The Sudden onset on the problem on all of my sites makes me think that Google changed some rules somewhere.

    Other important note: I added a new site to Google Analytics this morning (after discovering problem with all existing sites). Then added Google Analytics Dashboard and Analytics360 to the new site. The data loads from Google just fine on this new site.

    So the problem is only affecting existing sites.

  4. tomaxite
    Member
    Posted 1 year ago #

    I configured https://code.google.com/apis/console/ but it changed nothing. I contacted the creator of the plugin with Twitter. I hope he will respond.

  5. Carson McDonald
    Member
    Plugin Contributor

    Posted 1 year ago #

    I wonder if this is potentially caused by using older login information. Can one of you guys try going to the settings for the plugin and doing a auth reset and then logging in again using the OAuth system? You can reset auth by going into the plugin's settings and checking the "" checkbox then hitting save. You should then see the auth page where you will want to follow the instructions for using the "Login using Google's OAuth system." version.

  6. tomaxite
    Member
    Posted 1 year ago #

    @foodin65 Hello,
    I have not changed but everything is good now. It was perhaps wait 24 hours after registration to the console API. Is this is on your side?

  7. tomaxite
    Member
    Posted 1 year ago #

    @ Carson McDonald The problem occurred again. Is this would mean that we reach the Quotat? Many times I get disconnected and I used authentication "Login using Google's OAuth system." version. But nothing to do, I still have the same error message: "Error gathering data from Google analytics: usageLimitsuserRateLimitExceededUnregUser Rate Limit Exceeded. Please sign uphttps :/ / code.google.com / apis / consoleCould not load data".
    Think you can do something?

  8. Moondrop
    Member
    Posted 1 year ago #

    Same issue has occurred on my website.

    Error gathering analytics data from Google: usageLimitsuserRateLimitExceededUnregUser Rate Limit Exceeded. Please sign uphttps://code.google.com/apis/consoleError gathering analytics data from Google

    However, I have another website where the plugin is working perfectly fine. Both websites have been set up with Google Analytics for quite a while.

  9. foodin65
    Member
    Posted 1 year ago #

    @carson-mcdonald
    I found two articles on Google Groups talking about this issue and how to fix it. It has to do with the Analytics API change over from 2.3 to 2.4.

    This first article discusses the API change and how to update your application to work with the new AP: https://groups.google.com/forum/#!topic/google-analytics-data-export-api/93nTF-gg8cg/discussion%5B1-25%5D

    This second article discusses the exact issue I'm having and what needs to happen to fix it: https://groups.google.com/forum/#!msg/google-analytics-data-export-api/sJyyrD1RVdE/_6tN4f6Ax2IJ%5B1-25%5D

    I don't entirely understand what I need to do to fix this for my current sites having this issue, so if you have instructions after reading these... please let me know!

    Richard

  10. Matrix
    Member
    Posted 1 year ago #

    same problem here.. Let me know if you'll find a solution...

  11. briantallon
    Member
    Posted 1 year ago #

    Same here. Wish the dev would address it.

  12. Carson McDonald
    Member
    Plugin Contributor

    Posted 1 year ago #

    This isn't a simple issue to fix really. First off I haven't been able to trigger the limit in my testing. Second is that Google doesn't supply the actual limit they place on unregistered API calls so it is hard to tell just how bad of problem this is. It could be different for everyone.

    Getting access to registered API calls is something that can't be automated and I can't gauge how easy it will be for people to go through the process. Each person using the plugin would have to go through that process.

    Having said that, are any of you guys willing to install a test version of the plugin potentially? I may be able to add a new field into the options that takes an API key and tacks it on to every request. You would have to register for the API key and that is where the difficulty would come in but then I would know just how hard it is going to be.

  13. foodin65
    Member
    Posted 1 year ago #

    Hey Carson,

    I'd be more than happy to test the plugin for you. Also, I can provide you with login details and FTP access to sites where the issue is happening.

    Lastly, I'm very familiar with the process of setting up the API keys from google and I'd be more than happy to do a screen cast for you that you could put into the setting page of the plugin.

    Feel free to contact me here: http://www.richardmatthews.me/contact-me/

    I'll help in whatever way I can. Thanks!

  14. briantallon
    Member
    Posted 1 year ago #

    I would do the same and/or give you access to the sites I have it on that are breaking.

    Brian

  15. foodin65
    Member
    Posted 1 year ago #

    Hey Carson,

    I just wanted you to know that the 2.0.4 version of your plugin seems to be working now. Some site are requiring that I re-auth with Google. Others are just working now.

    Thanks for the fix.

  16. bart@dxb.be
    Member
    Posted 1 year ago #

    Hey there,

    I installed and reinstalled version 2.0.4 of Google Analytics Dashboard WordPress plugin but I still receive the same error.

    Error gathering analytics data from Google: usageLimitsuserRateLimitExceededUnregUser Rate Limit Exceeded.

    I receive this error in the Widget as in the Setup area.

    Any advice?

    Kind regards

    Bart

  17. staticdream
    Member
    Posted 1 year ago #

    Hi Carlson,

    2.0.4 doesn't seem to fix it for me I'm still getting issues, do you have an ETA on the fix for this?? If not I was thinking I could implement api handling into it pretty easily using this gem

    https://code.google.com/p/google-api-php-client/

    Let me know if your not doing it and I'll update it for you and email it to you so you can update it, unless of course you want to give me svn access to do it myself.

    Kind regards,

    Sean.
    Static Dream

  18. KarlDysonEndif
    Member
    Posted 1 year ago #

    Hi Carlson

    Getting the same issue here too. A fix would be great.

    Happy to test a beta version and give feed back if that would help.

    Cheers Karl

  19. garymgordon
    Member
    Posted 1 year ago #

    I also need a fix for this.

    Gary

  20. Carolyn_Madison
    Member
    Posted 1 year ago #

    Having the same issue. Any luck finding a fix for this?

    Thank you,
    Carolyn

  21. JiL
    Member
    Posted 1 year ago #

    And another usageLimitsuserRateLimitExceededUnregUser Rate Limit Exceeded
    Any fix yet?

  22. Cyberm@rmotte
    Member
    Posted 1 year ago #

    Same problem as stated on your blog. Can I tru the OAuth improvement?

  23. lauw8
    Member
    Posted 1 year ago #

    I had this problem for a couple of months now with one of my websites http://www.windowswebwereld.nl

    But today I solved it, only I don't know what exactly the solution was. Anyway, this is what I did:
    - Uninstalled the Google Analytics Dashboard plugin
    - Deleted everything in the database with "GAD" in it.
    - Then installed the Google Analytics Dashboard again.
    - After that I installed another plugin, the Google Analytics Dashboard Stats plugin. I configured that plugin, but I didn't liked this plugin as much as the other one, so I disabled this plugin very quickly.
    - Than suddenly the Google Analytics Dashboard worked again. Maybe the other plugin has reset something, but I don't know that for sure.

    Please tell me if this solution worked for you!

  24. Alin Mitrica
    Member
    Posted 1 year ago #

    foodin65 i solved my problem using this plugin:

    http://wordpress.org/extend/plugins/google-analytics-dashboard-for-wp/

    this plugin allows you to use your own Google API Project. Using your own Google API Project is almost impossible to reach the limit of 50.000 requests/day.

  25. EricaMueller
    Member
    Posted 1 year ago #

    I'm having this issue too:

    Error gathering analytics data from Google: usageLimitsuserRateLimitExceededUnregUser Rate Limit Exceeded. Please sign uphttps://code.google.com/apis/console

    Then there is a Please Try Again Later message on the settings page, so I can't un-authorize/re-authorize as some have suggested... those options aren't even there.

  26. supertrooper2
    Member
    Posted 11 months ago #

    I found the solution to this problem elsewhere:

    try dropping

    add_action( 'admin_init', 'delete_gad_options' );
    function delete_gad_options() {
    	delete_option( 'gad_login_pass' );
    	delete_option( 'gad_login_email' );
    	delete_option( 'gad_auth_token' );
    }

    in your theme functions.php file, refresh an admin page, then delete the code or comment it out.

  27. acohen5276
    Member
    Posted 11 months ago #

    I am having the same problem. @supertrooper2 I'd like to try your solution, but I'm not so tech savvy. What do you mean "refresh an admin page" and "'comment it out"?

    I tried uninstalling and reinstalling the wordpress Google Analytics Dashboard plug-in but it didn't fix it. Also, I turned on the Analytics API but that didn't do anything either.

    Any easy-to-follow help would be greatly appreciated. My site is http://www.neversaydiebeauty.com

  28. supertrooper2
    Member
    Posted 11 months ago #

    Acohen,

    Open your theme's functions.php file in your ftp upload window and copy / paste the above code into it. Then refresh a wordpress admin page.

    Finally delete the code from your theme's functions.php file in your ftp upload window (i.e. revert to the original file).

    If you then open the GAD settings page, you should find that this procedure has served to reset the plugin. The settings should again be visible.

    Hope this helps.

  29. acohen5276
    Member
    Posted 11 months ago #

    @supertrooper2 does it matter where in the function.php I place the code?

  30. acohen5276
    Member
    Posted 11 months ago #

    I placed the code that @supertrooper2 suggested toward the top of the function.php, saved the file, refreshed the page, deleted the code, saved the file, went to the GAD setting, logged in via the process on top, and got the same error message:

    Error gathering analytics data from Google: usageLimitsuserRateLimitExceededUnregUser Rate Limit Exceeded. Please sign uphttps://code.google.com/apis/console

    Please try again later.

    Did I do something wrong? Any other ideas?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic