WordPress.org

Ready to get started?Download WordPress

Forums

Google Analytics Dashboard
Please remove cURL requirement (3 posts)

  1. Curtiss Grymala
    Member
    Posted 2 years ago #

    Not all Web servers have cURL installed and compiled (as you're obviously aware, since there is an error handler built into the plugin that checks for cURL before anything is done). However, there is no reason to require cURL, since WordPress provides a sophisticated class to perform HTTP Requests.

    I've modified the current trunk version of this plugin to remove the cURL requirement, replacing it with the use of the WP_Http class, instead. I've generated a patch with all of these changes and pasted the contents of that patch at http://pastebin.com/dLbKJHqp.

    In my initial tests, it looks like everything is still working the way it should be, even on a server without cURL. I hope that helps. Thanks.

    http://wordpress.org/extend/plugins/google-analytics-dashboard/

  2. lesh
    Member
    Posted 2 years ago #

    Hi Curtiss, this sounds like a great mod. Where do I find the ga-lib.php to make these modifications?

  3. Carson McDonald
    Member
    Plugin Contributor

    Posted 1 year ago #

    Curtiss, thanks for the change. I have looked at changing this before but never got around to it. I'll try to integrate it into the next release.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic