WordPress.org

Ready to get started?Download WordPress

Forums

Google Analytics Dashboard
Could not load Google Analytics data. (38 posts)

  1. Harold Brown
    Member
    Posted 1 year ago #

    Message on the Dashboard Home page "Could not load Google Analytics data." Logged in and out, re-installed. Doesn't work for me.

    On the individual posts instead of the analytic data displaying I can see a small part of a large picture. I couldn't read what it said, but a "if you feel wrong place" text flashes up before the partial picture is displayed. I am sure it is part of the large picture that I see momentarily.

    http://wordpress.org/extend/plugins/google-analytics-dashboard/

  2. svehex
    Member
    Posted 1 year ago #

    I have a similar problem. I use https for my dashboard, but that shouldn't cause these messages.

    On the Home page of the Dashboard, it says "Could not load Google Analytics data", and on the Posts page it says "Request-URI Too Large
    The requested URL's length exceeds the capacity limit for this server."

    I believe these problems started after one of the latest WP upgrades.

    Please fix it.

  3. Matrix
    Member
    Posted 1 year ago #

    I have the same problem...

    Could you say me when someone'll find a solution?

    thanks
    Matteo

  4. billsmithem
    Member
    Posted 1 year ago #

    Same here. Site backend is all messed up unless I disable the plugin.

  5. Matrix
    Member
    Posted 1 year ago #

    @billsmithem I disabled the plugin too... :-(

  6. svehex
    Member
    Posted 1 year ago #

    I disabled, deleted, and went with WebNinja instead. Does the same, and works

  7. Harold Brown
    Member
    Posted 1 year ago #

    I switched to Wed Ninja as well. Works for me!
    Thanks svehex

  8. svehex
    Member
    Posted 1 year ago #

    My pleasure :)

  9. ppehrson
    Member
    Posted 1 year ago #

    Errr... WebNinja does NOT do the same. it does not show a small visitor graph in the post/page lists, one of the best features of this plugin.

    WebNinja, btw also doesn't work right now. They both give a 404 due to some google error?

  10. lapeter
    Member
    Posted 1 year ago #

    When I go to Dashboard- setting and then Google Analytics Dashboard, what I get is the message below. I don't know what to do or who to call. Can anybody help me as I really needGoogle Analytic

    Error gathering analytics data from Google: Error 404 (Not Found)!!1 *{margin:0;padding:0}html,code{font:15px/22px arial,sans-serif}html{background:#fff;color:#222;padding:15px}body{margin:7% auto 0;max-width:390px;min-height:180px;padding:30px 0 15px}* > body{background:url(//www.google.com/images/errors/robot.png) 100% 5px no-repeat;padding-right:205px}p{margin:11px 0 22px;overflow:hidden}ins{color:#777;text-decoration:none}a img{border:0}@media screen and (max-width:772px){body{background:none;margin-top:0;max-width:none;padding-right:0}} 404. That’s an error. The requested URL /analytics/feeds/accounts/default was not found on this server. That’s all we know.

  11. Carson McDonald
    Member
    Plugin Contributor

    Posted 1 year ago #

    For what it is worth, WebNinja is using the code I wrote for the Google analytics dashboard plugin. I will look into the original issue but I wanted to comment here that the 404 issue was fixed in the latest version of GAD.

  12. Harold Brown
    Member
    Posted 1 year ago #

    @ppehrson
    Yes Web Ninja does show the graph on the posts/pages. I have the 404 error as well.

    @Carson I just tried your plugin again and I have the same problem "Could not load Google Analytics data". I know that you didn't say you fixed it, but I thought I would give it a try.

    Thanks,

  13. Carson McDonald
    Member
    Plugin Contributor

    Posted 1 year ago #

    @Harold B Can you describe the issue you are seeing? The plugin should be working and there are a lot of things that could cause that error message. Does the data under the graph load at all or does nothing at all load? Can you try logging out completely and then log back in? You can do that by going into the plugin options for GAD and then selecting the "Forget Authentication" check box and hitting save. Then log in using the OAuth option.

    I'm somewhat worried that the Web Ninja plugin may have made my plugin unusable for people who have it installed. They took the majority of my code and put it into their plugin. My main concern is that they didn't bother to change the option names to not conflict with the ones from my plugin. You may actually have to completely delete that plugin to get GAD to work now.

  14. Harold Brown
    Member
    Posted 1 year ago #

    I get a message on the Dashboard Home page "Could not load Google Analytics data." On the pages and posts I get some type of error page display instead of the graph.

    http://photos.bhagavideo.com/photos/i-gXdGxXJ/0/XL/i-gXdGxXJ-XL.jpg
    http://photos.bhagavideo.com/photos/i-7hkJJCV/0/X2/i-7hkJJCV-X2.jpg

    When I got this message I had never loaded Web Ninja.

    I did the "Forget Authentication", but I have the same problem.

    Harold

  15. ppehrson
    Member
    Posted 1 year ago #

    @Harold B - I meant on the post and page OVERVIEW pages, where you can see all your pages/posts, in the admin area. I didn't see sh*t in there. Whereas the dashboard plugin, shows a small chart for each post/page.

  16. Harold Brown
    Member
    Posted 1 year ago #

    @ppehrson I guess I don't know what you are talking about because when I go to "All Posts" I see the small graph for each post. That is Web Ninja. If I use GAD I see the area where it wants to display the graph, but I get http://photos.bhagavideo.com/photos/i-gXdGxXJ/0/XL/i-gXdGxXJ-XL.jpg

    I had installed GAD first and got the above. Later I installed Web Ninja and the graphs for each post was displayed.

  17. Harold Brown
    Member
    Posted 1 year ago #

  18. ppehrson
    Member
    Posted 1 year ago #

    @Harold B

    Strange, because Web Ninja did NOT provide me with this display. :/ Guess I'll try it out again. Maybe there's a conflict.

  19. ppehrson
    Member
    Posted 1 year ago #

    So, just tried again. GAD works great. Web Ninja doesn't show sh*t in the posts and pages admin and there is NO way to turn it on.

  20. ppehrson
    Member
    Posted 1 year ago #

    BTW, 4 (including me) says Web Ninja is broken in WP 3.4.1 ... so MIGHT I be right?

    BTW it gives a 404 on the settings page BECAUSE WEB NINJA IS NOT UPDATED TO MATCH THE NEW GOOGLE ANALYTICS SETUP!

  21. hirai
    Member
    Posted 1 year ago #

    I can't speak english.
    libxml ver2.6.19 don't work.
    Message on the Dashboard Home page "Could not load Google Analytics data."
    but libxml ver2.7.3 work.

  22. svehex
    Member
    Posted 1 year ago #

    It works fine for me.

  23. Harold Brown
    Member
    Posted 1 year ago #

    @ppehrson I don't know that there is a right or wrong. For me everything is as I stated for both Web Ninja and GAD. Obviously for other people it works. I can only assume a conflict of some type. I have a lot of plug-ins installed.

  24. eharris
    Member
    Posted 1 year ago #

    I'm having the same problem with Google Analytics Dashboard, but I'm not sure that the plugin is the problem. Yoast's Google Analytics plugin won't authenticate with GA anymore. I have to manually enter my Google Analytics ID to get it to work (which works for inserting the code, but not for retrieving the results). GA Dashboard authenticates, but fails to work otherwise.

    Strangely, I'm using this pair of plugins on two websites sitting on the sames shared hosting account. One works, and the other doesn't. Both are using the same version of WordPress, Yoast's GA plugin, and this GA Dashboard plugin. I have absolutely no clue what the problem is, but I'm wondering if it's on Google's end.

  25. Fmllphoto
    Member
    Posted 1 year ago #

    I'm having a slightly different problem.

    When it goes to show the graph on the dashboard, I get the "Could not load Google Analytics" error. But when I go to look at the posts list, I get an error that says I do not have permission to access "admin-ajax.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

    My permissions are fine. What else could it be?

  26. garymgordon
    Member
    Posted 1 year ago #

    Carson,

    The problem is back. Can you please look into this asap for all of us?

    Thanks,
    Gary

  27. garymgordon
    Member
    Posted 1 year ago #

    Carson,

    Is there any further help you can provide?

    Gary

  28. Carson McDonald
    Member
    Plugin Contributor

    Posted 1 year ago #

    I believe this is related to recent (last 8 months) changes that Google made to the analytics api. They introduced a much more rigid way of authenticating users as some people may already know. With that they introduced a limit to the number of calls you can make to the service without a product key. That product key isn't something I can include in the plugin because it is specific to each user who would use it. Google doesn't specifically say how many calls you can make without that key but it should be large enough for most people. However I believe there have been issues with other plugins causing that quota to be used very quickly. And if you are using the embedded stats display on heavily visited pages you could also run through that quota pretty quickly. I will work on getting the ability to add a key to the admin area and see if that helps.

  29. garymgordon
    Member
    Posted 1 year ago #

    That makes sense. I hope you can figure out a way to enable individual users to enter their Google API key into your app. Please keep us informed as to your progress, as this is quite important (as I'm sure you realize).

    Thanks,
    Gary

  30. Tom
    Member
    Posted 1 year ago #

    It doesn't work for me neither. "Could not load Google Analytics data."

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic