WordPress.org

Ready to get started?Download WordPress

Forums

Google Analyticator
[resolved] Upgrade to 6.3.4 and still Auth Error (19 posts)

  1. mmwine
    Member
    Posted 1 year ago #

    I've reset 2 or 3 times, deauth and reset, all of that. I still get this error:

    There was an Analytics API service error 400:Error fetching OAuth2 access token, message: 'invalid_grant'

    http://agoodtimewithwine.com

    http://wordpress.org/extend/plugins/google-analyticator/

  2. Completeheartblog
    Member
    Posted 1 year ago #

    Same here

  3. Video User Manuals
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm - very strange. Does it output any other error code?

    Trying to sort this bug out - only affecting a few people!

  4. Video User Manuals
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Guys,

    To get to the bottom of this now, is it possible you can head over to our site:

    http://www.videousermanuals.com/about/

    Drop us an email with temporary logins to your site so we can see for ourselves whats going on.

    Thanks
    Brian

  5. Milber
    Member
    Posted 1 year ago #

    Same here

  6. rhenderson813
    Member
    Posted 1 year ago #

    Hi, we are also having the same problem on multiple sites, is there a solution yet?

  7. rhenderson813
    Member
    Posted 1 year ago #

    Hi,

    Google Analytics has changed some of their privacy settings, so now we have to put in an authentication code to allow the plugin to work.

    Login to your Google Analytics account and then in a new tab/window open up the plugins section of the site.

    You need to deactivate and delete the plugin, then re-install it. Once you have done that go to settings and click where it says "Click Here" and then click Allow and copy and paste that code into the first page of the plugin settings. Once you have done that it should work as it did before.

  8. ccalvert
    Member
    Posted 1 year ago #

  9. Video User Manuals
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks CCalvert.

  10. mojo74
    Member
    Posted 1 year ago #

    Same for me and I don't know what to do. I followed all ccalvert steps but it still not working...

    Warning: curl_exec() has been disabled for security reasons in /public_html/wp-content/plugins/google-analyticator/google-api-php-client/src/io/Google_CurlIO.php on line 112
    There was an Analytics API service error 0:Error fetching OAuth2 access token, message: ''

  11. Gagan Jain
    Member
    Posted 1 year ago #

    Same has mojo has problem...
    Plugin does gets enable in first place itself.

  12. ccalvert
    Member
    Posted 1 year ago #

    mojo74,

    Warning: curl_exec() has been disabled for security reasons

    This is something that you should talk to your webhost about. It looks like they've disabled a PHP function that the plug-in needs.

    Charles

  13. Video User Manuals
    Member
    Plugin Author

    Posted 1 year ago #

    Charles is correct.

    I am going to mark this as resolved, as mojo74 and Gagan Jain issues are both hosting issues.

  14. Milber
    Member
    Posted 1 year ago #

    Sorry, I don't think this is resolved. The plugin does not work for me although curl is definitely activated. The only thing that is disabled is allow_url_fopen for v. good reasons concerning security exploits. If you're plugin relies on the latter, it's practically unusable. No reliable webhost will activate this for you unless you've got a dedicated server and take liability for any damage yourself.

  15. Gagan Jain
    Member
    Posted 1 year ago #

    My web host Is saying following

    We have found out the issue to be incompatibility b/w the plugin and the latest PHP version. Google has mentioned in its forums that there is no solution to it till they bring out the fix for this plugin.
    The only solution we can provide you at this time is to migrate your account to a server with older version of PHP which is compatible with this plugin.

    Is any way i can get old version for plugin and test

  16. Gagan Jain
    Member
    Posted 1 year ago #

    Ok i asked my web host to provide where google mentioned it
    so here is it
    https://groups.google.com/forum/#!msg/google-api-php-client/S1GBH6-2KOg/FQmMG4hAKU0J

    error means curl was unable to find a certificate bundle on your system for validating SSL connections.  Since this is a frequent issue for PHP deployments, the latest version of the PHP client (on trunk) contains its own bundle for validating SSL connections when making API requests.
    The fix for this is currently available on trunk (it is being tested and stabilized) and hasn't been released yet.
  17. ccalvert
    Member
    Posted 1 year ago #

    @Milber, did you follow the steps in my blog post?

  18. Milber
    Member
    Posted 1 year ago #

    Yes, on all of my websites. I enter the authentication code but I don't get any settings page.

  19. Video User Manuals
    Member
    Plugin Author

    Posted 1 year ago #

    The Google Library does require SSL for it to Authenticate back to itself.

    The Google Library is constantly updating as mentioned in that Google Group. I'll take a look in the trunk and see if there have been any updates that may fix this issue for you.

    Cheers,
    Ben

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.