WordPress.org

Ready to get started?Download WordPress

Forums

Google Analyticator
OAuth2 Access service error? (7 posts)

  1. MCM
    Member
    Posted 1 year ago #

    There was an Analytics API service error 0:Error fetching OAuth2 access token, message: ''

    I started getting this on my website, please can somebody advise how to correct it. I cannot see the google dashboard any longer as well.

    http://wordpress.org/extend/plugins/google-analyticator/

  2. mascor
    Member
    Posted 1 year ago #

    Same problem...

    Google Analytics UID: There was an Analytics API service error 400:Error fetching OAuth2 access token, message: 'invalid_grant'

    Google Analytics Panel says that the monitoring code is installed

    What's the problem?

    Thanks

  3. Milber
    Member
    Posted 1 year ago #

    I second this. After installing 6.3.4 I tried to authenticate and wind up on an almost empty settings page displaying a warning that GA is disabled. Selecting enable doesn't update the page; neither can I enter my UID. Errors given:

    Warning: require_once(service/Google_Utils.php) [function.require-once]: failed to open stream: No such file or directory in /[path to my install directory]/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php on line 20

    Fatal error: require_once() [function.require]: Failed opening required 'service/Google_Utils.php' (include_path='.:/usr/bin') in /[path to my install directory]/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php on line 20

  4. wingfingerbill
    Member
    Posted 1 year ago #

    Yes. I'm getting the same...

    Warning: require_once(service/Google_Utils.php) [function.require-once]: failed to open stream: No such file or directory in /[path to my install directory]/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php on line 20

    Fatal error: require_once() [function.require]: Failed opening required 'service/Google_Utils.php' (include_path=[mine's a bit different here]) in /[path to my install directory]/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php on line 20

    WordPress 3.4.2.

  5. pepper2
    Member
    Posted 1 year ago #

    I have the same problem
    Wordpress 3.4.2

  6. ccalvert
    Member
    Posted 1 year ago #

    Same problem, aslo WordPress 3.4.2. Google Analyticator 6.3.4.

  7. ccalvert
    Member
    Posted 1 year ago #

    I figured out how to fix my problem. It seems that Google Analytics now requires an authentication code. I have documented the steps here: http://www.celticwolf.com/blog/2012/10/02/wordpress-google-analyticator-error-analytics-api-service-error-0error-fetching-oauth2-access-token/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.