WordPress.org

Ready to get started?Download WordPress

Forums

Google Analyticator
Memory Error (5 posts)

  1. KerriM
    Member
    Posted 3 years ago #

    Hi, it looks like this was a problem that was resolved long ago, but it seem it's back. I just installed version 6.1.1 of Google Analyticator on WP 3.0 and I get a memory error both on the settings page (when I try to authenticate), and on the dashboard widget:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1966080 bytes) in /home/admin/public_html/xxx.com/wp-includes/class-simplepie.php on line 5410

    Increasing the memory limit does not solve it.

  2. James
    Happiness Engineer
    Posted 3 years ago #

    Not every memory bump method works on every server. Here are four ways to increase PHP's memory allocation:

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)
    
    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M
    
    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '64M');
    
    4. Talk to your host.
  3. KerriM
    Member
    Posted 3 years ago #

    MacManX, I understand the different methods of increasing memory limit. I am on a VPS server and have tried increasing the memory limit to a ridiculous amount (128M) (as verified by phpinfo()), and the error persists. I don't believe this plugin should be consuming that much memory, so I am concerned that there is an issue with the plugin itself (as there was in a previous version).

  4. KerriM
    Member
    Posted 3 years ago #

    Okay, I just discovered that this is not an issue solely tied to this plugin (it only started showing up when I installed the plugin, so that was my original assumption).

    I am now getting this error on another dashboard widget (but only when I'm not logged in as Admin, and even after I uninstall the Analyticator), so there is something else causing this.

  5. cavemonkey50
    Member
    Posted 3 years ago #

    FIrst off, your error message indicates your memory limit is only 32MB. If that's the same error message you get after increasing the memory, your increased limit isn't taking.

    From there, I would just do what you're doing with disabling plugins. There is probably a combination of plugins that aren't working well together. To help figure this out, look for a memory plugin that can help by displaying memory usage on pages. Enable and disable plugins and see the different effects.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic