WordPress.org

Ready to get started?Download WordPress

Forums

Google Analyticator
In-page analytics errors with google analyticator (13 posts)

  1. helloari
    Member
    Posted 2 years ago #

    wheni go to "In-Page Analytics" in the new version of GA i get this error:

    Problem loading In-Page Analytics
    We've identified problems in your setup. These may cause problems loading In-Page Analytics.
    --Your site doesn't load ga.js from Google. If you host the Google tracking code on your own servers, it isn't updated automatically and can miss important changes.
    --We didn't find a tracking snippet on your site. In-Page Analytics cannot load. Please make sure you have tracking installed correctly. If your snippet is included in a separate JavaScript file, you'll have to manually check it is being loaded correctly.

    any idea if this is something to do with google-analyticator? i have not spent much time troupble shooting this myself yet.

    http://wordpress.org/extend/plugins/google-analyticator/

  2. kcomphlint
    Member
    Posted 2 years ago #

    I have noticed this as well on a few of my sites. Any resolution or explanation available yet?

  3. helloari
    Member
    Posted 2 years ago #

    no resolution yet....

  4. Usayd
    Member
    Posted 2 years ago #

    Same issue here, any clues?

  5. eminentstyle
    Member
    Posted 2 years ago #

    Any progress on this? Can't work out why its not working as the plugin appears to implement the tracking correctly? :-s

  6. cavemonkey50
    Member
    Posted 2 years ago #

    Hello everyone, there are a few solutions to this problem. To prevent counting admin users in the stats, Google Analyticator removes the ga.js tracking code for admin users logged into WordPress. This can cause problems with the in-page analytics if you're logged in, as Google is expecting the tracking code to be there. If you want to take advantage of the in-page analytics functionality, here are you're options:

    1) Log out of WordPress before launching the in-page analytics.

    2) Enable tracking of admin users in Google Analyticator's settings. This can be found in the advanced section.

    3) Change the way Google Analyticator disables tracking for admins. In the same advanced section, there is an option to use an admin variable to prevent tracking. Enable that option, and then setup the corresponding settings in Google Analytics via this FAQ: http://forums.ronaldheft.com/viewtopic.php?f=5&t=309

    Hope this helps!

  7. fahadusmani
    Member
    Posted 2 years ago #

    no, problem is still there....

  8. cavemonkey50
    Member
    Posted 2 years ago #

    In what way is the problem still there? Did you try any of the solutions above?

  9. fahadusmani
    Member
    Posted 2 years ago #

    Can you tell me where is Google Analyticator's settings?

    I have enable it from my wordpress dashboard, but same result.

    Thank you.

  10. cavemonkey50
    Member
    Posted 2 years ago #

    From your WordPress admin, click on Settings > Google Analytics. All of Google Analyticator's settings are on that page.

  11. fahadusmani
    Member
    Posted 2 years ago #

    Thank you very much for your help. I got it.

    but problem is still there.

    :(

  12. fahadusmani
    Member
    Posted 2 years ago #

    Problem is solved.

    My Google Analytic inpage view problem is solved, and I am giving you same steps to follow. I hope that many of you can find your solution the way i found.

    I think, in my case problem was that, while filling online info for my blog, I entered my blog address is as http://www.pmstudycircle.com , but in actual it was only http://pmstudycircle.com . Means my blog url was set without "www" and I entered it with "www" in profile setting.
    So first I changed my layout to "old version", then i went to Analytic setting and then under "Website Profile " I clicked at Edit. Here I changed address of my blog url to without www.

    After doing it, I checked my inpage analytic, and it was working.

    Please you all who is seeing this message, do this and try. I hope that after following steps outline in this message, your problem will be solved.

    Thanks.
    Fahad

  13. eminentstyle
    Member
    Posted 2 years ago #

    Thanks Fahad, my blog is confiigured in GA the other way around (listed without www when I do use it).

    Will give this a try and let you know but the logic sounds plausible.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic