WordPress.org

Ready to get started?Download WordPress

Forums

Google Analyticator
Getting BORED with this!!!! Failures, revisted ad infinitum (7 posts)

  1. Peter Le C
    Member
    Posted 1 year ago #

    I have noticed that most of blogs are running the latest version are throwing this error randomly:

    The sites have been authenticated many times, I have reset patiently and still we get this: >

    Now today this error has popped up on 6 domains I run. Last time I went in via the admin screen they were fine.

    Frankly I'm for jacking this plugin!
    ------------------------------------------------------------------

    Fatal error: Uncaught exception 'Google_AuthException' with message 'Error refreshing the OAuth2 token, message: '{ "error" : "invalid_grant" }'' in /home/cheappho/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php:279 Stack trace: #0 /home/cheappho/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php(239): Google_OAuth2->refreshTokenRequest(Array) #1 /home/cheappho/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php(216): Google_OAuth2->refreshToken('1/PQrNjOMqOgMOm...') #2 /home/cheappho/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/service/Google_ServiceResource.php(166): Google_OAuth2->sign(Object(Google_HttpRequest)) #3 /home/cheappho/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/contrib/Google_AnalyticsService.php(183): Google_ServiceResource->__call('list', Array) #4 /home/cheappho/publ in /home/cheappho/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php on line 279

    http://wordpress.org/extend/plugins/google-analyticator/

  2. Video User Manuals
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Peter

    There are a couple of people with this error. It appears to be the Google system refreshing the auth token, and causing this error.

    We are looking at this currently, and hope to release a new update (6.3) within the next week.

    Where does the error actually show up? I'd love to be able to fix it, but very hard to when I can't reproduce it on any of my installations.

    Thanks, Ben

  3. Peter Le C
    Member
    Posted 1 year ago #

    Hi Ben the error message appears on the dashboard of WordPress, in the usual place! I checked 14 blogs today, 9 had this error, its not restricted to a particular server either, i.e. its cross Server.

    As far as I can see the only commonality is that the Google analytics login is the same.

    Obviously it requires a reset each time which is a pain in the a**

    Yesterday on one WPress login I had a brief message whilst re-setting permission to authorise with Google, which said Method Not Allowed or words to that effect. Flashed up briefly before giving me the Google success code to paste into the app. Probably not relevant but...

  4. Video User Manuals
    Member
    Plugin Author

    Posted 1 year ago #

    We have a beta plugin we are trying to test at the moment and debug. Want to get this sorted before releasing another version.

    Just to confirm - are all your sites individual installs, or MU site?

    Ben

  5. Peter Le C
    Member
    Posted 1 year ago #

    Hi Ben

    All are individual sites NOT MU. It would be good to get this sorted - I can't see a pattern other than one theme is more effected than others. ( Suffusion, current release)

    Thanks

    Peter

  6. Peter Le C
    Member
    Posted 1 year ago #

    Enough already, enough.
    I'm running a large quantity of blogs and this plug in is NOT working for me.
    Same error as the start of this thread, I can't be bothered with having to reset the plugin EVERY time I wish to see a quick picture.
    There are other options out there... Thanks for trying.

  7. Peter Le C
    Member
    Posted 1 year ago #

    This issue was NOT resolved I've just seen that it has been marked as resolved. I've walked away from the plugin as free or not it just doesn't do what it says on the box.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.