WordPress.org

Ready to get started?Download WordPress

Forums

Google Analyticator
[resolved] Analyticator Settings Page Gets a 404 Error (7 posts)

  1. blinovitch
    Member
    Posted 1 year ago #

    After updating to version 6.3 of Analyticator, I get a 404 error trying to load the settings page (mysite.com/wp-admin/options-general.php?page=ga_activate) to follow the activation process outlined in the video.

    Any suggestions as to what may be causing this?

    http://wordpress.org/extend/plugins/google-analyticator/

  2. blinovitch
    Member
    Posted 1 year ago #

    Having updated to 6.3.2 of the plugin, I'm still getting the 404 error as clicking Settings tries to load mysite.com/wp-admin/options-general.php?page=ga_activate.

    I realized that the URL above isn't correct, as my site's WordPress installation is in a subfolder of the www directory. When I added the sub-directory, I was able to get to the activation page and input the code.

    However, on clicking Save & Continue I get the 404 error again as the URL doesn't include the subfolder. Adding the subfolder to the URL at this step doesn't work, so I'm still unable to activate the plugin.

  3. francesdath
    Member
    Posted 1 year ago #

    I have the same problem. For me changing bloginfo('url') to site_url() in google-analyticator.php as well as adding /wordpress/ to the "Save & Continue" button seems to work, though now the UID throws "There was an Analytics API service error 400:Error fetching OAuth2 access token, message: 'invalid_grant'", which may or may not be connected.

  4. Jason Kemp
    Member
    Posted 1 year ago #

    It is the path error for the sub directory see other thread regarding sub directory. It shows as resolved but based on it failing on 3 of my sites and working on one - it is still broken.

  5. blinovitch
    Member
    Posted 1 year ago #

    With version 6.3.3 released, I installed it to see what happens.

    The good news: the preview of the Settings URL now includes the WordPress installation subfolder (http://www.mysite.com/subfolder/wp-admin/options-general.php?page=google-analyticator.php.

    The bad news: on clicking the Settings link, the browser is redirected to http://www.mysite.com/wp-admin/options-general.php?page=ga_activate, which is missing that subfolder element.

  6. blinovitch
    Member
    Posted 1 year ago #

    According to the new author Ben over in this thread, 6.3.3 needs one line updated to allow the plugin to activate with Google.

  7. francesdath
    Member
    Posted 1 year ago #

    It seems to authenticate and work fine for me now, thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic