WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Google Analyticator] Analyticator causes Widget Page error (20 posts)

  1. Donnacha
    Member
    Posted 4 years ago #

    Enabling the plugin causes the widgets page to stop, at the Analytics Widget, with the following error:

    Fatal error: Call to undefined function curl_init() in /home/abtalk/public_html/wp-content/plugins/google-analyticator/class.analytics.stats.php on line 48

    Any ideas?

  2. cavemonkey50
    Member
    Posted 4 years ago #

    What that error says is cURL is not installed on your PHP installation. cURL is required for the widget to function and is typically present on all PHP installations.

    Therefore, here's what we recommend:

    1) Get cURL working on your server. If you don't know how, contact your host. This is recommended as a lot of PHP code takes advantage of cURL.
    2) We're going to check for cURL in the next version and disable the widget if it is not present.
    3) If you can't get cURL working, downgrade to 3.0.3. Nothing else changed other than the new stats widget.

  3. patyuen
    Member
    Posted 4 years ago #

    Some kinds of message would be nice. This prevents the save button from appearing on the widget page and there are more than a few people having problems.
    http://wordpress.org/support/topic/263738?replies=6#post-1063111

  4. spiralwebconsulting
    Member
    Posted 4 years ago #

    patyuen have you updated to the latest version?

    We recently put out a fix for the problem you were referencing so that the widget will not even appear at all if cURL is not enabled on your server. If you are still experiencing this issue in the latest version, please let us know.

  5. patyuen
    Member
    Posted 4 years ago #

    I have no idea if cURL is enabled on the server. I'm hosting this on 1and1.com. It is the latest version.

  6. Guddi
    Member
    Posted 4 years ago #

    I'm having the same problem as patyuen. It's only on my hosting providers server though. I have the same setup on a local computer and everything works fine.

    Here's a screenshot of the page, http://images.upload2world.com/get-5-2009-upload2world_com_inyo.png

    I don't have access to the error log. If i look at the HTML source the output stops after <div class="widget-control">

    My hosting provider (claim to) support cURL and i have the latest version of your plugin installed.

  7. Bryan84
    Member
    Posted 4 years ago #

    I am having this error on my widget page

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1966080 bytes) in /home/bryan/public_html/wp-content/plugins/google-analyticator/simplepie.inc on line 5353

  8. cavemonkey50
    Member
    Posted 4 years ago #

    For those of you with save button issues, what browser are you using?

    Furthermore, do you have a user/pass entered in Google Analyticator's settings page? If you don't, try entering your user/pass and see if you can edit the widgets again.

    If that does solve the issue, please report back. I want to get feedback on this bug fix before I push it out and find out it may not solve the problem.

  9. Guddi
    Member
    Posted 4 years ago #

    I've entered my user/pass and the problem's still there.

  10. cavemonkey50
    Member
    Posted 4 years ago #

    We're still working on trying to resolve this issue, and we would really appreciate some feedback in this process. We have put together a test version that could potentially solve this issue, but we need someone with this problem to test it. If you're experiencing this issue, download the file here and please report back.

  11. Guddi
    Member
    Posted 4 years ago #

    No luck, everything looks the same. Thanks for trying though

  12. manon1165
    Member
    Posted 4 years ago #

    I don't get any error messages, just all my widgets disappearing on the admin side, though they're working just fine on the frontend. Plus because I can't see any widgets in the widgets page, I can't add or delete any of them as well. Not a big problem as I'll just add the code to my footer manually.

  13. Crooksy
    Member
    Posted 4 years ago #

    Yep I'm having the same problem as Manon. Must be something to do with 1&1? Don't know enough to know what that could be.

    Manon - you can just deactivate the analyticator plugin, add/remove/adjust your widgets, then reactivate.

    Not ideal, but does the trick for me.

  14. cavemonkey50
    Member
    Posted 4 years ago #

    Upgrading to WordPress 2.8 and Google Analyticator 4.2.2 will solve the issue.

  15. Tim Griffin
    Member
    Posted 4 years ago #

    Am loving the functionality of this plugin! Just installed for the first time. WordPress 2.8, Analyticator 4.2.2 - installed on two separate sites.

    Widget Administration panel now displays available widgets and NO widgetized areas available for editing. I guess the option that Crooksy mentioned could work... but not ideal...

    I did not insert user name and password for Gooogle analytics in the plugin options. Appears to be tracking but am hoping there is a way around this little hitch.

    Thanks!

  16. daviddebeer
    Member
    Posted 4 years ago #

    Interesting!
    I discovered this thread by accident while browsing to find a solution to my widget problem. Don't know how to describe it except that all the widgets (in the admin backend; front is fine) is kind of squished together, with the page stopping loading at the google analytics widget and I cannot edit, delete, move anything or access screen options.

    The only thing I did in the last 20 minutes was to upgrade the plugin to 4.3.

    Deactivating the plugin does fix the problem, although as has been pointed out it's not an ideal solution. It's a good plugin this, never given me any problems before. Hopefully this is a minor glitch.

  17. cavemonkey50
    Member
    Posted 4 years ago #

    For those of you who are reporting the issue with a version since 4.2.2, can you provide a little more details.

    1) Browser and version.
    2) WordPress version.
    3) Plugin version.
    4) Is the problem reproducible every time?
    5) Is the username and password filled out on the option page?
    6) Anything else you can provide to help track down this issue.

  18. Tim Griffin
    Member
    Posted 4 years ago #

    1) Browser and version.
    Firefox 3.0.11

    2) WordPress version.
    2.8

    3) Plugin version.
    4.3 (Not 4.2.2)

    4) Is the problem reproducible every time?
    Two separate sites - same results. Plugin active - no ediatble widgets. Plugin deactivated. Widgets back to full function/editability.

    5) Is the username and password filled out on the option page?
    username and password not filled in.

    6) Anything else you can provide to help track down this issue.
    PHP5 5.2.9
    MySQL 5.0.67

    Other?

    Thanks for looking into this and providing an awesome tool for WordPress!

  19. cavemonkey50
    Member
    Posted 4 years ago #

    Thank you for the debug information. Version 4.3.1 that was just pushed out will fix the issue. Optionally, for a quick fix, just enter something into the username field (doesn't have to be an actual username).

  20. daviddebeer
    Member
    Posted 4 years ago #

    yup, it's fixed now. Thanks!

    for reference, my details are the same as tgriff's, except I only have the ony blog.

Topic Closed

This topic has been closed to new replies.

About this Topic