WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Google AJAX Translation] Not showing translation button / links (13 posts)

  1. growdesign
    Member
    Posted 4 years ago #

    I've installed this plugin but the button/link doesn't show up. The theme I'm using is a custom theme and the url is: http://www.degrendel.co.za/
    Thanks in advance!

    http://wordpress.org/extend/plugins/google-ajax-translation/

  2. hopsieu
    Member
    Posted 4 years ago #

    I've installed this plugin but the button/link doesn't show up. The theme I'm using is a custom theme and the url is: http://www.degrendel.co.za/
    Thanks in advance!

    http://wordpress.org/extend/plugins/google-ajax-translation/
    me too !!!!

  3. denys281
    Member
    Posted 4 years ago #

    I've installed this plugin but the button/link doesn't show up.

    +1 in opera 10.5. With oldest versions of Opera and other browsers it’s ok!)

  4. lizcan1
    Member
    Posted 4 years ago #

    Hi

    I've installed this plugin too but see no change to my page at all. I'm using Atahualpa theme, WordPress 2.9.1 and Firefox.

    Any clues please?

    Liz

  5. monodistortion
    Member
    Posted 4 years ago #

    Sorry for the delay.

    I looked at the site http://www.degrendel.co.za/ and it looks like you're using a copy of jQuery in the theme folder:
    http://www.degrendel.co.za/wp-content/themes/degrendel/js/jquery-1.3.2.js
    which is conflicting with the version of jQuery included with WordPress that is used by this plugin:
    http://www.degrendel.co.za/wp-includes/js/jquery/jquery.js?ver=1.3.2

    The best way to avoid this kind of conflict is the use the enqueue function in your functions.php file to use the WordPress version of jQuery. See these pages:
    http://codex.wordpress.org/Function_Reference/wp_enqueue_script
    http://matty.co.za/2010/03/enqueue-javascript-in-wordpress/

  6. SheltieJim
    Member
    Posted 4 years ago #

    I'm having a similar problem on my blog http://SheltieTales.com I've updated to WordPress 2.9.2 and Atahualpa 3.4.6 and have installed the Google Ajax Translation plugin version 0.5.1. The plugin works fine with the Kubrick theme, but the button '[ Translate ]' does not appear at all with Atahualpa.

    I've confirmed that I do not have multiple copies of jQuery installed anywhere. The only copy of jQuery on my blog is in my /public_html/wp-includes/js/jquery/ directory. Of course, my /public_html/wp-content/plugins/google-ajax-translation/ directory has the file jquery.translate-1.4.1.min.js

    Any guidance would be most welcome.

    Oh, one more thing: I don't understand why the generated HTML contains this: <div class="translate_block" style="display: none;"> Surely, "display: none" means what it says, and yet the content of the <div> displays just fine on at least the Kubrick theme.

    Thanks!

  7. monodistortion
    Member
    Posted 4 years ago #

    It looks like there is a problem or problems with your widgets.

    The Google AdSense widget is not closing all of its HTML tags. All the widgets below that are nested inside of it.

    Then the text widget with the BlueHostAd also does not have its HTML tags closed. All the widgets below that are nested inside of it.

    This is also breaking your footer so that it doesn't show up.

    Try fixing or disabling those two widgets.

    The style="display: none;" is to hide the translate buttons if JavaScript is disabled or if the JavaScript doesn't load properly.

  8. SheltieJim
    Member
    Posted 4 years ago #

    monodistortion, many thanks! I'm rather embarassed about the AdSense widget failing to close its HTML tags...I suppose it's something I did without realizing it; I fixed it. The BlueHost ad seemed to me to have all its tags closed, but I've deleted it anyway. The [Translate] links have appeared and work.

    Now, though, another problem reared its ugly head: all the gravatar images are now empty squares :( If it ain't one thing, it's one (or two) others...

  9. SheltieJim
    Member
    Posted 4 years ago #

    Ummm...gravatars are displaying now. I have no idea what happened, but they suddenly reappeared and all I did was refresh the page a few times.

    Thanks again for your help, monodistortion!

  10. monodistortion
    Member
    Posted 4 years ago #

    Glad I could help!

    One thing you may want to do is change the background color of the language popup to something that matches your theme.

  11. mies909
    Member
    Posted 3 years ago #

    Hi monodistortion!

    Same problem here Not showing translation links.
    I try to load default theme and it works. I look for hours to find a solution. I hope you can look at my website/theme: http://www.italo.nu

  12. mies909
    Member
    Posted 3 years ago #

    Found my problem in me footer.php i add this line and it works
    <?php
    /* Always have wp_footer() just before the closing </body>
    * tag of your theme, or you will break many plugins, which
    * generally use this hook to reference JavaScript files.
    */

    wp_footer();
    ?>

  13. jkintzele
    Member
    Posted 3 years ago #

    This is an excellent plugin! A few things...

    - When do you expect to have a fix for Opera 10.5+ ready?

    - The [Translate] link only appears on the first three entries on my homepage. Is there a setting I can change to extend the number of stories with a translation link to the number present?

    - Would it be possible for you to extend the CSS file so that it has placeholder entries for all elements that can be styled? I would like to center the "[Translate]" link and style it as a button. Adding "text-align: center !important;" etc. in the obvious place doesn't seem to work.

Topic Closed

This topic has been closed to new replies.

About this Topic