WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: GoCodes] WP-Admin redirects to homepage after plugin upgrade (9 posts)

  1. Dave P.
    Member
    Posted 5 years ago #

    I just upgraded the gocodes plugin on my WordPress install, now every time I go to the wp-admin, it redirects me back to the homepage of the site. Any ideas?

    The only way I've been able to resolve it so far was by deleting the /gocodes directory in my plugin directory.

  2. redwallhp
    Member
    Posted 5 years ago #

    This bug is being investigated. It seems to be specific to certain server configurations though.

  3. Dave P.
    Member
    Posted 5 years ago #

    Ahh, if it helps I'm on a Media Temple Grid server. Let me know if you need me to post any config stuff or anything that may help.

  4. redwallhp
    Member
    Posted 5 years ago #

    Do you know what version of PHP you're running? Also, what version of WordPress?

  5. Dave P.
    Member
    Posted 5 years ago #

    PHP version 4.4.8
    Wordpress version 2.7.1

  6. wp-tam
    Member
    Posted 5 years ago #

    I am having the same problem. I have tried WordPress v. 2.7.1 and v. 2.6.5. I have tried erasing my entire site and reloading WordPress. I've tried reloading it with Fantastico and with SimpleScripts. I've tried putting GoCodes in a subfolder in the Plugins folder and I've tried putting GoCodes directly in the Plugins folder without a subfolder. I've tried changing the .htaccess file and I've mostly left it as-is.

    I'm using PHP v. 4.4.9 on HostMonster.

    Since this other guy had this problem when he upgraded, I'll try installing a previous version of GoCodes instead and see if that fixes it.

    Thanks!

  7. redwallhp
    Member
    Posted 5 years ago #

    Interesting.

    Could either of you temporarily replace your copy of GoCodes with this debugging version? http://www.box.net/shared/iullul5pzb

    It will output some debugging info every time a page is loaded. Just install it, type a redirect URL into your browser, and save the output. (Then remove the modified plugin, otherwise your blog will have debugging information outputted at the top.

    If you could post the information here, it would help with my debugging.

  8. Dave P.
    Member
    Posted 5 years ago #

    Just ran the debug for you, hope this helps (I changed the paths):

    REQUEST: /go/test
    URL TRIGGER: go
    STRPOS: yes
    GOCODE KEY: test

    Warning: Cannot modify header information - headers already sent by (output started at path/to/site/wp-content/plugins/gocodes_servertest/gocodes_servertest.php:52) in path/to/site/wp-includes/pluggable.php on line 850

  9. redwallhp
    Member
    Posted 5 years ago #

    I just released 1.3.3. I think I may have fixed it this time. Try it out. :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags