WordPress.org

Ready to get started?Download WordPress

Forums

Geo Mashup
sensor message (6 posts)

  1. zoomzoom2
    Member
    Posted 2 years ago #

    Hello

    I just tried geo smashup for the first time, it looks great but I have problem with a messgage that always comes on the screen saying something like "...define sensor true or false..."

    I tried to find solution but I did not succeed, anyone has suggestion?

    thanks

    http://wordpress.org/extend/plugins/geo-mashup/

  2. Dylan Kuhn
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry I missed this - it sounds like a bug! If you can produce the problem again I'd like to see it...

  3. topleveladministrator
    Member
    Posted 2 years ago #

    Just noticed this error on ipad + iphone Im using V3 maps and noticed on map-render.php for v2 you are using an ampersand before this parameter, but on v3 there is no ampersand? could that be the reason for this error?

    The google maps APi server rejected your request, the sensor parameter specified in the request should be set to either "true" or "false"

    as per this post elsewhere.
    http://maps.google.com/maps/api/geocode/json?address=1600+Amphitheatre+Parkway,+Mountain+View,+CA&sensor=false

    where that last bit (&sensor=false) is the important bit. It's a new thing and that query parameter specifies whether you're on a location aware device (such as an iphone).

  4. Dylan Kuhn
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for the info, but I don't think the ampersand is the issue (it's the first parameter in the v3 URL, where a question mark is the required separator). Geo Mashup maps using V3 are working fine for me on an iPod touch - do you have a URL where I can see the error?

  5. Dylan Kuhn
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, from the link sent in private I can see that no script arguments are being supplied. Something must be stripping them off - if you have any plugins active that might do this try deactivating them.

  6. Dylan Kuhn
    Member
    Plugin Author

    Posted 2 years ago #

    Remembered that there is an issue for this already with some relevant info:

    http://code.google.com/p/wordpress-geo-mashup/issues/detail?id=479

    I see the problem in all browsers on my mac.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags