WordPress.org

Ready to get started?Download WordPress

Forums

Genesis Featured Widget Amplified
[resolved] Older Posts Not Working (12 posts)

  1. jwade1991
    Member
    Posted 1 year ago #

    Hi there,

    After clicking on "older posts" at the bottom left of the page more than twice, (so essentially the 3rd time), my site loses functionality. I used to be redirected to a page that says "oops, this link appears to be broken".

    Now the site just freezes and doesn't load anymore on the 3rd click.

    Any ideas?

    thanks,
    John Wade

    http://wordpress.org/extend/plugins/genesis-featured-widget-amplified/

  2. jwade1991
    Member
    Posted 1 year ago #

    This is my blog

    http://www.paveyourlife.co

  3. Nick the Geek
    Member
    Plugin Author

    Posted 1 year ago #

  4. jwade1991
    Member
    Posted 1 year ago #

    I tried the solutions. No go. I also didn't understand some of them. Man, I still haven't figured this out yet. Now it freezes after just one click on "older posts".

    http://www.paveyourlife.co

  5. Nick the Geek
    Member
    Plugin Author

    Posted 1 year ago #

    Please disable all plugins and test, even the plugins you don't think are the problem. Please make sure they are all disabled at once, not just one at a time because sometimes more than one plugin is to blame.

    If this gets better you can start turning on your plugins in small groups. I like to go 4 at a time so I get done 4 times faster and narrow the problem to just the 4 plugins when things break again.

    If the problem you are trying to diadnose is with one of the StudioPress plugins you may leave that active to see if the other plugins are conflicting with it.

    Once you know which plugin(s) is the problem please contact the plugin developer for support.

    If disabeling all plugins does not resolve this please report back with as much information as you can about what happened during this part of the testing.

  6. jwade1991
    Member
    Posted 1 year ago #

    Hi,

    I did exactly as you said. Disabled them all at once.

    The genesis featured widget amplified plugin is the problem.

    After two clicks on "older posts", I get this message on a blank screen

    "PHP Fatal error: Maximum execution time of 300 seconds exceeded in E:\USERS\paveyourlife\www\404error.php on line 3

    This is the url that gives that error message: http://www.paveyourlife.co/index.php/page/3/

    Any thoughts?

  7. jwade1991
    Member
    Posted 1 year ago #

    No ideas eh?

  8. jwade1991
    Member
    Posted 1 year ago #

    I also just noticed that when I click on archives, even though there are 4 months available, no matter which month I click on, I can only get my most recent 10 posts.

    This link is supposedly my archives for the month of June, but it shows July posts.

    http://www.paveyourlife.co/index.php/2012/06/

    Clicking my "older posts" button won't take me further back than my most recent 10 posts either.

  9. Nick the Geek
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry I've been away for the last week. The 404 error is because your posts per page setting in the Reading Settings does not match the widget settings for the number of posts to show. I have a filter that use to work, but it seems that some changes make it so that the filter is simple running too late.

    This means you need some code
    Please add this to your functions.php file

    add_action( 'pre_get_posts', 'child_change_home_query' );
    /** Changes the query on the home page*/
    function child_change_home_query( $query ) {
    
    if( $query->is_main_query() && $query->is_home() ) {
    $query->set( 'posts_per_page', '5' );//change the '5' to the posts setting for your widget
    }
    
    }

    The white screen appears to be a problem with your 404 error file on the server.

  10. jwade1991
    Member
    Posted 1 year ago #

    You are very kind. You fixed the "older posts" problem. Thank you so much for you dedicated effort. Is there anywhere I can rate you or give you any other great feedback?

    Any ideas now why my archives won't go earlier than july 5th, even if I click on the month of may?

    http://www.paveyourlife.co/index.php/2012/05/

  11. Nick the Geek
    Member
    Plugin Author

    Posted 1 year ago #

    I honestly don't know how things work in the WP forums for "ranking" or other feedback. As for the second question, honestly I don't know but please start another thread for that in the appropriate part of the forums.

  12. jwade1991
    Member
    Posted 1 year ago #

    okay, thanks very much!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic