WordPress.org

Ready to get started?Download WordPress

Forums

Gallery
[resolved] single image without prettyPhoto (10 posts)

  1. Krzysztof Kudłacik
    Member
    Posted 2 years ago #

    Gallery generated ok, but when I click on single photo it is shown without prettyPhoto template/plugin

    http://wordpress.org/extend/plugins/gallery-plugin/

  2. bestwebsoft
    Member
    Plugin Author

    Posted 2 years ago #

    Hello,

    Please provide URL to your gallery page.
    It is possible that the main jQuery file is not included / connected into template or it's happens because you have a conflict between your plugin and scripts of other plugins.
    We need to check your gallery page to provide any suggestions and solution.

    [sig moderated as per the Forum Rules]

  3. Krzysztof Kudłacik
    Member
    Posted 2 years ago #

    Here is the URL: http://born66.net/?page_id=5108

    Below you find complete list of active plugins in my instance of WordPress:
    Akismet
    Out-of-the-box SEO for your WordPress blog.
    Broken Link Checker
    CodeStyling Localization
    Dynamic Widgets
    Gallery Plugin
    Google Keyword Tracker
    Google XML Sitemaps
    Jetpack by WordPress.com
    jQuery Collapse-O-Matic
    Last.Fm Records
    Last modified items widget
    Lightbox 2
    Most Popular Tags
    Multiple Galleries
    Polska data
    Quote Comments
    Random Tags Cloud Widget
    SEO Friendly Images
    Sierotki
    Silverlight Audio Player for WordPress
    Similarity
    Simple Yearly Archive
    Tags Page
    Theme Test Drive
    Ultimate Noindex Nofollow Tool
    W4 post list
    WDP Ajax Comments
    Wordpress Popular Posts
    WP-DBManager
    WP Original source

  4. Krzysztof Kudłacik
    Member
    Posted 2 years ago #

    version 2.10 is still broken - with above reported bug.

  5. bestwebsoft
    Member
    Plugin Author

    Posted 2 years ago #

    Hello,
    1) There is no conflict with these plugins.
    2) It's unclear, regarding which page you are talking about: 'when I click on single photo it is shown without prettyPhoto template/plugin'
    For 'http://born66.net/?page_id=5108' page - prettyPhoto is not allowed.
    For 'http://born66.net/?gallery=druga' page - you can check prettyPhoto on the screenshot

    Regards,
    Oksana

  6. Krzysztof Kudłacik
    Member
    Posted 2 years ago #

    There is no conflict with these plugins.

    Thank you for confirmation! :)

    For 'http://born66.net/?page_id=5108' page - prettyPhoto is not allowed.

    prettyPhoto is not allowed it's suprise: how can I not allow prettyPhoto scripts? :-o
    I thought both test galleries have the same config.

    On my computer (Win 7/64, Pro, Firefox 11.00) on both two galeries I don't have no even slight mark of prettyPhoto, see actual screens:
    http://born66.net/allegro/druga.jpg
    http://born66.net/allegro/edge.jpg

  7. Krzysztof Kudłacik
    Member
    Posted 2 years ago #

    oh, here is the news - I've checked other browsers: under Chrome prettyPhoto is shown and works just fine, but under MSIE Explorer 9.0 there is no prettyPhoto (the same as under Firefox).

    My guess: Java Scripts used in prettyPhoto are differently parsed?
    I am not a programmer, so apologise for simple guesses :-)

  8. Krzysztof Kudłacik
    Member
    Posted 2 years ago #

    I tried to install solo prettyPhoto plugin to see any difference, plugin istalled but with some errors - I cannot quote them here, because my instance of WP is in Polish language :)
    But those warnings from prettyPhoto installer mentioned some "unexpected data from script" and contained advise to unistall the plugin.

    I hope all my remarks will be some help.

  9. bestwebsoft
    Member
    Plugin Author

    Posted 2 years ago #

    Hello,

    Here is gallery screenshots, how it's look like in my ie9, everything is working correctly, on the screenshot you can see page URL.

    Perhaps js scripts are not allowed in ie9. Or higher security level is selected (and part of scripts doesn't work).

    prettyPhoto is not allowed it's suprise: how can I not allow prettyPhoto scripts? :-o
    I thought both test galleries have the same config.

    regarding this question - Prettyphoto is not allowed because we consider that it don't need to be placed on the cover of the album.

    Regards,
    Oksana

  10. Krzysztof Kudłacik
    Member
    Posted 2 years ago #

    Here is gallery screenshots, how it's look like in my ie9, everything is working correctly, on the screenshot you can see page URL.

    :) please don't misunderstand me - I assume you telling truth when say "everything is working correctly" --- what I really try is to find a clue why it doesn't work fine on my side. Because of this I find your promising plugin broken.

    Perhaps js scripts are not allowed in ie9. Or higher security level is selected (and part of scripts doesn't work).

    Take a look at screenshot: http://born66.net/allegro/msie-9-security.jpg
    MSIE on my workstation works with default config, because primarily I use Firefox/Chrome browsers.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic