WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Frontpage-Slideshow] 'About Default Link' setting will not save (15 posts)

  1. VikingBrent
    Member
    Posted 4 years ago #

    So I've got the plugin set up and displaying correctly on my site's index page; the only problem is that I'd like to have the images link to their corresponding blog post and have been unable to do so thus far. Checking the notes in the Edit Post section I see that if I leave the 'Slide Link' field empty then the slide image should link to the post, provided I've set this option in the plugin Admin page.

    So I set the 'About Default Link' setting to:

    'If no link is specified: Don't use the slide url'

    I click Preview and test it out on the Admin page and everything works correctly. I click Save the settings and apply them immediately but the Default Link setting goes back to 'use the slide url.' For some reason the plugin will not save this setting.

    Troubleshooting steps I've attempted thus far include deactivating all other plugins and changing themes to the WordPress Default. I'm running WP 2.8.6 on a local install using MAMP with a custom theme.

    Any help would be greatly appreciated.

    Thanks,

    Brent

  2. jeff_
    Member
    Posted 4 years ago #

    Hi,

    does the plugin working fine ? if yes, its just the admin page that not displays the right information, I dont have time right now to have a serious look on the code, but what you are describing smells like I made a booboo on the admin page code : the option is saved but not displayed properly.
    Will be corrected on next release.

  3. VikingBrent
    Member
    Posted 4 years ago #

    Hi Jeff,

    To answer your question, no the slideshow does not link to any of the posts being displayed, it just links back to:

    #frontpage-slideshow

    I've tested all the other available options in the Admin settings for the plugin, and this is the only one that doesn't work. The workaround I'm using at the moment is to copy and paste the permalink for the post into the Slide Link field in the Edit Post screen, which does work; it would just be great to save the extra step.

    Thanks for the quick reply.

  4. jeff_
    Member
    Posted 4 years ago #

    hum... is there any javascript error on both admin page and page that displays the slideshow ? Would be a great help for me to know that.

    I got a lot of work by now, so I wont be able to work on frontpage slideshow plugin to correct that bug fast... but with all elements in hand, I could troubleshoot faster.

    Thanks for your help.

  5. VikingBrent
    Member
    Posted 4 years ago #

    I setup the plugin on my live site and its working perfectly. I'm not sure why this particular function doesn't work with my local WP install, but happily its no longer an issue.

    For your troubleshooting: there were no javascript errors on the admin page or the index.

  6. jeff_
    Member
    Posted 4 years ago #

    weird thing... thanks anyway for your help

  7. VikingBrent
    Member
    Posted 4 years ago #

    Hi Jeff,

    A quick follow up. I recently had this problem pop up again on my site and after playing with things for a bit I discovered that, for whatever reason, when I switched the sort order setting from 'date' --- 'descending' to 'date' --- 'ascending' and then back again, this unfroze the default link selection and I was able to reselect 'If no link is specified: Don't use the slide url.'

    Just wanted to let you know.

  8. jeff_
    Member
    Posted 4 years ago #

    hummm what a strange behavior !

    there a re too many wird thing about this plugin... gotta use some exorcism... :)

    Thanks for this precious WBR (Weird Behaviour Report) I'll have a look on it.

  9. robanna
    Member
    Posted 4 years ago #

    Hi Jeff,

    I'm having this same problem and nothing's fixing it. It's live at apexprd.org

    When I switch from Ascending to Descending then the Link changes from Don't Use to Use but the result is the same; no link to the post when clicking on the image.

    All I want is to use the default link.

    Thanks
    Rob

  10. robanna
    Member
    Posted 4 years ago #

    I don't know why but it's working now. <shrug>

  11. robanna
    Member
    Posted 4 years ago #

    and now it not working again.
    I changed the button color and it broke.

  12. robanna
    Member
    Posted 4 years ago #

    Here's my DB entry:
    a:1:{s:6:"values";a:25:{s:15:"fs_is_activated";i:1;s:7:"fs_cats";a:1:{i:0;s:2:"76";}s:9:"fs_slides";s:1:"4";s:15:"fs_show_buttons";s:1:"1";s:12:"fs_shortcode";s:18:"FrontpageSlideshow";s:9:"fs_insert";s:9:"frontpage";s:28:"fs_default_link_to_page_link";s:1:"1";s:13:"fs_main_width";s:5:"485px";s:14:"fs_main_height";s:5:"260px";s:14:"fs_slide_width";s:3:"70%";s:16:"fs_buttons_width";s:3:"30%";s:21:"fs_placeholder_height";s:5:"205px";s:22:"fs_button_normal_color";s:4:"#000";s:21:"fs_button_hover_color";s:7:"#5c8d0c";s:23:"fs_button_current_color";s:7:"#5c8d0c";s:19:"fs_buttons_position";s:5:"right";s:15:"fs_text_bgcolor";s:4:"#000";s:15:"fs_text_opacity";s:3:"75%";s:13:"fs_main_color";s:4:"#fff";s:13:"fs_font_color";s:4:"#fff";s:20:"fs_main_border_color";s:4:"#444";s:13:"fs_transition";s:4:"fade";s:10:"fs_orderby";s:4:"date";s:8:"fs_order";s:4:"DESC";s:15:"fs_show_comment";s:1:"1";}}

  13. robanna
    Member
    Posted 4 years ago #

    So, it works in the preview but not on the live site.

  14. marythegr8
    Member
    Posted 4 years ago #

    I cannot get this to work on the live site either.

    It works inthe preview.

    I can't even find where to set this in the code.

    How can we fix this?
    Mary

  15. jeff_
    Member
    Posted 4 years ago #

    @marythegr8 : please, start a new thread and read the forum to transmit some useful informations.

Topic Closed

This topic has been closed to new replies.

About this Topic