WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Front-end Editor] WordPress MU Problem (domain mapping) (5 posts)

  1. Richard Tape
    Member
    Posted 4 years ago #

    Hi Scribu,

    Firstly, this is an awesome plugin. Really helping many people, I would imagine.

    There is a slight problem with WordPress MU however. The plugin itself works just great on WPMU, however, if you start to domain map your blogs (using the domain mapping plugin) then this plugin doesn't actually work. I'm assuming it's because the plugin has some sort of dependency on where the page is being loaded in the browser to actually load the relevant javascripts etc.

    So, if I have my WPMU install at http://www.myWPMUinstall.com/ and blogs are created at http://blog1.myWPMUinstall.com/ etc. I then domain map this domain to http://www.blog1.com/

    Before domain mapping I visit http://blog1.myWPMUinstall.com/, the plugin works fine, so I can edit content from the front-end at will.
    However, as soon as I domain map the blog, I need to visit http://www.blog1.com/ and the plugin then fails to work.

    If you need any more information from me, then please don't hesitate to ask! Thanks very much in advance, from a cold and blustery Manchester, England

    Richard

  2. scribu
    Member
    Posted 4 years ago #

    Try making the siteurl and home options match the ones you're using for domain mapping.

    PS: I didn't see this topic until now because it didn't show up in http://wordpress.org/tags/front-end-editor (yeah, it sucks).

  3. wable
    Member
    Posted 4 years ago #

    Hi Scribu, I'm afrad this did not make a difference for me.

    I am mapping a domain which is the same as the site subdomain. Also leaving the home settings as default.

    blog.domain.com
    Map to
    blog.com

    Any other ideas?

    Cheers

  4. scribu
    Member
    Posted 4 years ago #

    Erm... I guess hacking the plugin to generate the right ajax_url:

    http://plugins.trac.wordpress.org/browser/front-end-editor/tags/1.8/core.php?rev=230729#L58

  5. wable
    Member
    Posted 4 years ago #

    Thanks for the reply Scribu, I haven't worked it out yet. Does anyone have any ideas?

    Cheers

Topic Closed

This topic has been closed to new replies.

About this Topic