WordPress.org

Ready to get started?Download WordPress

Forums

Front-end Editor
[resolved] Front End Editor adds extra paragraphs at every edit (6 posts)

  1. dancelotlindy
    Member
    Posted 2 years ago #

    New paragraphs are added every time opening the post to edit. Happens in different themes. Don't want paragraphs to be added by the editor.

    http://wordpress.org/extend/plugins/front-end-editor/

  2. scribu
    Member
    Plugin Author

    Posted 2 years ago #

    Those are necessary for Aloha Editor to work. The same thing happens with the rich text editor in the admin.

    If you want to disable Aloha Editor, you can do so from WP-Admin -> Settings -> Front-end Editor.

  3. dancelotlindy
    Member
    Posted 2 years ago #

    Thanks for your response, scribu. I love that you've made it possible to edit from the post, pages and more, that's fantastic. I can see a huge amount of coding was necessary to make it happen. It works great for single paragraph text.

    I have seen paragraphs added by WP admin visual editor but am not seeing that happen now. I can edit these same posts in WP admin visual mode without paragraphs added by WP.

    I disabled WYSIWYG editor, I think that's what you mean by Aloha Editor and I see html in the post to edit. I want to set up Front End Editor in WYSIWYG mode for basic users who don't know html.

    After clicking save in Front End Editor, the paragraphs are added so I don't see how to ever be rid of the extra paragraphs. I don't understand how FEE can be used in WYSIWYG mode without corrupting the post with extra paragraphs. I tried using PS Disable Auto Formatting which didn't make any difference - I thought that might help. Does everyone just use FEE in html mode when there is more than one paragraph?

  4. dancelotlindy
    Member
    Posted 2 years ago #

    I just the watched the FEE 2.0 youtube demo video http://youtu.be/c6P7M_oG-NY and see that you can select a single paragraph by mousing over it. When I mouse over text in FEE 2.2, the whole field is selected and instead of boxing a paragraph, there is a vertical bar to the left of the whole field, I can't figure out how to select just one paragraph for editing. Am I doing something wrong?

  5. scribu
    Member
    Plugin Author

    Posted 2 years ago #

    The option to edit a single paragraph at a time was removed because it didn't work very well.

    If you want to use Aloha Editor, then why do you care about the paragraphs? You can't see them while editing anyway. If I'm missing something, please add a screenshot.

    Also note that they are added by WP anyway when the post is rendered on the front-end.

  6. dancelotlindy
    Member
    Posted 2 years ago #

    Hi Scribu,
    I was going to send you screen shots except the problem has resolved itself, no more extra paragraphs are being added. I don't think I made any change other than rebooting overnight. I had tested FEE 2.2.1 in IE and Firefox and 2 different WordPress installations on different hosts with different setups, 1 running WP 3.2.1, the other WP 3.3.1. Maybe there was a plugin conflict that caused a problem stuck in cache on my PC?

    If I see this issue again, I'll see if I can identify any specific suspect causes. Was definitely a problem that made FEE unusable, glad it stopped!

    Thanks for considering my problem and taking the time to reply. Keep up the great work!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic