WordPress.org

Ready to get started?Download WordPress

Forums

FriendlyCase
[resolved] Problems with accents (11 posts)

  1. MXClass
    Member
    Posted 2 years ago #

    Hi,

    I have installed this plugin but I have some problems with accents.

    Instead of "Máquina De Lavar Pressão" I have "MÁquina De Lavar PressÃo"

    Could you help me please?

    Thank you for your help

    http://wordpress.org/extend/plugins/friendlycase/

  2. kelter
    Member
    Plugin Author

    Posted 1 year ago #

    I'm not seeing this occur in our test environment. Can you please send me a link to your site? As a test, please copy and paste the text, "Máquina De Lavar Pressão" into the Post title field.

  3. MXClass
    Member
    Posted 1 year ago #

    Hi,

    Thank you for your support

    You can see the error on my test site

    Instead of " Amarraçãoo Definitiva, União De Casais, Resultado Garantido"

    Gives me this result in title "AmarraÇÃo Definitiva, UniÃo De Casais, Resultado Garantido"

    http://www.mxclasse.com/anuncio/amarracao-definitivauniao-de-casaisresultado-garantid/

    or

    Istead of "Máquina De Lavar Pressão"
    Gives this in title "MÁquina De Lavar PressÃo"

    http://www.mxclasse.com/?s=M%C3%A1quina+De+Lavar+Press%C3%A3o&cp_state=0&scat=0&sa=pesquisar&refine_search=yes

    Thank you

  4. kelter
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, Yes - I now see this issue. We'll need to look at the accent characters. Will take a look and see what can be done.

  5. MXClass
    Member
    Posted 1 year ago #

    Thank you very much for your support.

  6. kelter
    Member
    Plugin Author

    Posted 1 year ago #

    This is going to probably take a bit more than expected to do this correctly - as we probably have to look at the various language's accent marks, since some such as Irish have particular rules in which first letter are always lowercased. For now, it's on the roadmap.

  7. MXClass
    Member
    Posted 1 year ago #

    Ok,

    Thank you

  8. MXClass
    Member
    Posted 1 year ago #

    Hi,

    I think if you replace "strtolower" for "mb_strtolower" he works.

  9. kelter
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, this seems to be correct. Let me look at it tomorrow and I'll most likely commit it to version 1.0.5. Thank you!

  10. kelter
    Member
    Plugin Author

    Posted 1 year ago #

    OK - Committed 1.0.5 - Try it out and let me know if any other issues. Otherwise please Mark the Topic as resolved. Thanks again.

  11. MXClass
    Member
    Posted 1 year ago #

    Thank You.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.