WordPress.org

Ready to get started?Download WordPress

Forums

Formidable Forms
[resolved] Form response not sent if "Your Email" field included in form (5 posts)

  1. Jeff Brock
    Member
    Posted 2 years ago #

    Hi there -- If I include a "Your Email" field for form submitters (or if a user enters an email address in any field), the form is throwing an error, followed by a success message, and I don't receive any form response. However, if I remove the "Your Email" field from the form, everything works fine, and the form response is emailed to me. Any ideas? Thanks!

    "Warning: mail() [function.mail]: SMTP server response: 504 5.5.2 <premfs18>: Helo command rejected: need fully-qualified hostname in C:\[...snip...]\wp-content\plugins\formidable\classes\models\FrmNotification.php on line 78

    Warning: mail() [function.mail]: SMTP server response: 554 5.7.1 <[...whatever email address the user entered in the form appears here...]>: Relay access denied in C:\[...snip...]\wp-content\plugins\formidable\classes\models\FrmNotification.php on line 78

    Your responses were successfully submitted. Thank you!"

    P.S. The plugin's UI for building forms is lovely.

    http://wordpress.org/extend/plugins/formidable/

  2. sswells
    Member
    Plugin Author

    Posted 2 years ago #

    It sounds like your web host won't allow emails to be sent from other email addresses. Please install an SMTP plugin (and configure the SMTP settings, not just PHP mail). This will force the email to be sent from the email address you configure in the SMTP settings.

  3. Jeff Brock
    Member
    Posted 2 years ago #

    Thanks for the reply -- I had originally thought that could be the problem, but there is an SMTP plugin running and WordPress does send emails successfully. The odd thing is that Formidable will work properly and send me an email notification, but only if the person filling out the form doesn't include an email address in any of the text-entry fields.

  4. sswells
    Member
    Plugin Author

    Posted 2 years ago #

    This is working as planned. When an email address is found in the form submission, it is used in the email so you can reply to the email to respond to the user. There are settings for this in the Pro version.
    http://formidablepro.com/knowledgebase/emailing-form-responses/

    Here's a post with code changes you can make if you don't want to set up SMTP:
    http://blog.strategy11.com/forum/formidable/not-receiving-emails-same-as-others/#p1101

  5. Jeff Brock
    Member
    Posted 2 years ago #

    I implemented the code changes you linked to and that worked like a charm for me -- thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags