WordPress.org

Ready to get started?Download WordPress

Forums

Football Pool
[resolved] Polish fonts in bonus questions (6 posts)

  1. Maly77
    Member
    Posted 2 years ago #

    When I use Polish fonts in the body questions on the blog I see the question marks - where is the problem?

    http://wordpress.org/extend/plugins/football-pool/

  2. AntoineH
    Member
    Plugin Author

    Posted 2 years ago #

    That has to be an encoding issue. If polish Fonts work in your regular wordpress posts and pages, then check your table/field settings. Look for the collation setting in a wordpress table and use the same setting for the pool_wp_* tables. Maybe that will work.

  3. AntoineH
    Member
    Plugin Author

    Posted 2 years ago #

    Correct settings should be utf8_general_ci.

    I changed the install scripts for a future update. You can change it manually in phpMyAdmin or wait a few days for my next version of the plugin.

  4. Maly77
    Member
    Posted 2 years ago #

    I changed the collation setting for the pool_wp_* tables - it does not work.
    I added a new question - there is still no Polish fonts.

  5. AntoineH
    Member
    Plugin Author

    Posted 2 years ago #

    Did you also change the column settings?

    Example for the bonusquestions-table (but make sure you also change the bonusquestion_types- and bonusquestions_useranswers-table):

    ALTER TABLE pool_wp_bonusquestions DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
    ALTER TABLE pool_wp_bonusquestions CHANGE question question TEXT CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL DEFAULT '';
    ALTER TABLE pool_wp_bonusquestions CHANGE answer answer VARCHAR( 200 ) CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL DEFAULT '';
  6. Maly77
    Member
    Posted 2 years ago #

    Yes - now works.
    I changed all other columns in the database.
    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.