WordPress.org

Ready to get started?Download WordPress

Forums

Foliopress WYSIWYG
"Fatal error" when insert images (7 posts)

  1. FlavioSerra
    Member
    Posted 2 years ago #

    Excellent editor, clean and effective. I love it. I have one problem though...

    When trying to insert images with the "quick insert", or when I click on WP box "featured image", I get this error:

    Fatal error: Class 'kfmSession' not found in /var/www/web100/web/wp-content/plugins/foliopress-wysiwyg/fckeditor/editor/plugins/kfm/initialise.php on line 337

    As a "turnaround" I enabled "Wp uploader buttons" but I would still like to be able to use the WP "featured image".

    Hope I can get help! Thanks in advance!

    http://wordpress.org/extend/plugins/foliopress-wysiwyg/

  2. FlavioSerra
    Member
    Posted 2 years ago #

    Ups... I realized I CAN use the standard WP uploader buttons to select the featured image.... ie. my turnaround works in all cases... but I am leaving the topic open, in case someone wants to post a fix to the problem with the code :-)

  3. FolioVision
    Member
    Plugin Author

    Posted 2 years ago #

    Hello FlavioSerra,

    we are providing active support for any Foliopress WYSIWYG issues here: http://foliovision.com/seo-tools/wordpress/plugins/wysiwyg

    Please post your issues over there and we will have a look.

    Thanks for trying our FV WordPress plugins!

    Thanks,
    Martin

  4. Edrard
    Member
    Posted 2 years ago #

    Thats wasnt hard. I had same. Problem is becouse __autoload function do not work properly. All what u need its edit wp-content/plugins/foliopress-wysiwyg/fckeditor/editor/plugins/kfm/initialise.php and add after:

    if(!function_exists('__autoload')){
            function __autoload($class_name) {
                    if (file_exists(KFM_BASE_PATH . 'classes/'  . $class_name . '.php'))
        require_once KFM_BASE_PATH . 'classes/' . $class_name . '.php';
            }
    }

    this line:

    spl_autoload_register(__autoload);

    Atlest, its helped to me

  5. FlavioSerra
    Member
    Posted 2 years ago #

    Thanks Edrard.

    Your suggestion workes in the sense that I don't get any longer a "fatal error" message, now Foliopress opens a window divided in two columns, where the left one has a sort of navigation menu: "Directories" and "Directory properties" while the column to the right is blank.

    Not as a big issue, as I am happy with the WP image uploader, but maybe Foliovision should look at the issue when they make a new release.

  6. Edrard
    Member
    Posted 2 years ago #

    I whoud like to help u, but need to see u error.log file. In any ways, try to put 777 on images folder and to all internal folders aswell.

  7. FlavioSerra
    Member
    Posted 2 years ago #

    Many thanks Edrard, very kind of you!

    Just...I don't think we should invest more time on the issue ;-)

    As I said, I am happy with the standard WP uploader. I don't need to investigate further on a "custom" solution for my own sake, but I copied Foliopress on their forum, in case they want to follow up on the case for future relases of the plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic