WordPress.org

Ready to get started?Download WordPress

Forums

FLV Gallery
Skip This One - No Documentation. (3 posts)

  1. kevin2i
    Member
    Posted 4 years ago #

    Another Plugin with no documentation. Why do people take the time and effort to write a plugin, then provide a "hide and seek" approach for users trying to figure out how to use it?

    75% of the FLV > settings page is blank. Plenty of room to slip in the directions explaining short code usage.

    Once installed, there is no documentation on how to use the plugin. If you go to your 'plugins' page, and find flv-gallery - there are two links that go to a church site (which, by the way looks great, but I'm not in Georgia). You actually have to go to wordpress.org > Extend > plugins, and search for the 'flv gallery' plug-in page to find this:
    [flvgallery video="/path/to/videos/video1.flv" title="Title for Video 1" caption="Optional Caption" thumbnail="/path/to/thumbnails/thumbnail1.jpg" url="" url_text=" url_icon="" width="400" height="225"]
    Simple enough - but I use over 2 dozen plugins. How am I suppose to remember this? - Skip it, I'll find another plugin.
    Lack of basic documentation = failed plug-in.

    http://wordpress.org/extend/plugins/flv-gallery/

  2. russell.todd
    Member
    Plugin Author

    Posted 4 years ago #

    sorry to disappoint...

    This is the first plugin I developed, so I'm not certain what the best practices are. As with most plugins (I suspect) I just took a utility I wrote for a specific need and then tried to make it work as a plugin others could use.

    Most of what you seem to be asking about is on this page: http://wordpress.org/extend/plugins/flv-gallery/installation/

    Are you looking for something more? Should these instructions be repeated on the Settings page?

  3. aritmetic
    Member
    Posted 4 years ago #

    Hi Russel, I have a question about the Flv-gallery, I have some trouble disabling the autostart and the buffer size, I edit the flvgallery.php but the problem persist, you can say me what I doing wrong? I think in this part of code is the problem

    <script type="text/javascript">
    jQuery(document).ready(function() {
    jQuery("a.flvgallery-link").click(function(evt) {
    evt.preventDefault();
    var flvId = jQuery(this).attr('href');
    var video = flvconfig[flvId].video;
    var width = flvconfig[flvId].width;
    var height = flvconfig[flvId].height;
    var streamer = flvconfig[flvId].streamer;
    var flashvars = { wmode: "opaque",
    allowfullscreen: "false",
    autostart: "false",
    file: "video",
    bufferlength: "0",
    volume: "100",
    backcolor: "FFFFFF",
    frontcolor: "000000",
    lightcolor: "000000",
    screencolor: "000000" };
    if (streamer) {
    flashvars["streamer"] = streamer;
    flashvars["type"] = "rtmp";
    }

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic