WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: flshow Manager] Conflicts in jQuery plugins and wrong syntax... (1 post)

  1. akerman
    Member
    Posted 4 years ago #

    Tested the majority of carousels available as plugins for WP 2.8 the last couple of days and want to share the following:

    1. All carousels/galleries that are based on jQuery have a hard time coexisting with other plugins that has already called this library. Like Thickbox, Lightbox, Shopp and many others. So if you already have an active jQuery plugin, it is VERY likely that the new plugin (in this case flShow) will break (not load).

    2. The PHP script to load the flShow is not complete/could be improved, since the majority of users out there aren't programmers (neither am I...;-)

    Ex:
    <div style="clear:both; width:690px; height:300px;">
    <?php if (is_page('Home') ) {
    flshow($id['1648']);
    }
    ?>
    </div>

    Code above makes room for a 690x300 (width/height) container and also decides to ONLY show it on the homepage. Code above inserted in 'index.php' and after the 'get_header();' (so it ends up as the first item before the 'loop' (the content pane in the middle).

    This can depend a little bit on what template you use, but in general you only want the carousel on one page, not all, right?

    One way to solve these conflicts can be to use the plugin in an Iframe and thereby avoid conflict. Not nice but functional. (Works for Smooth Gallery as a tick-box selection.)

    Regards
    Akerman

    http://wordpress.org/extend/plugins/flshow-manager/

Topic Closed

This topic has been closed to new replies.

About this Topic