WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Flickr Gallery] Compatibility Issue with 2.8? (23 posts)

  1. macrunning
    Member
    Posted 5 years ago #

    Was wondering if anyone else was having problems with Flickr Gallery and WordPress 2.8? My flickr gallery will not allow clicks on the top tabs (Photostream, Photosets, Most Interesting)... Also Lightbox will not come up instead it just links directly to Flick website when clicking on the photos. You can see it at http://connect.marcheitzford.com/?page_id=3

    I am trying to view in Safari 3.1.2

    Any help would be appreciated.
    Thanks.

  2. DanCoulter
    Member
    Posted 5 years ago #

    Are you still having this problem? It's working fine for me on your site. Also, you are not using WordPress 2.8. You still have WordPress 2.7.1 installed.

  3. duping812
    Member
    Posted 5 years ago #

    I upgraded wp to 2.8 and got the exact same problems. I use only the default code [flickr-gallery], the problems show up in both firefox and ie. Here is the link of my gallery:
    http://thdp.org/gallery/

  4. duping812
    Member
    Posted 5 years ago #

    I solve the problem today by installing a plugin Shadowbox JS, which is a more advanced media viewer. I think there are some code conflicts in the lightbox.

  5. fewpeople
    Member
    Posted 5 years ago #

    Was wondering if anyone else was having problems with Flickr Gallery and WordPress 2.8? My flickr gallery will not allow clicks on the top tabs (Photostream, Photosets, Most Interesting)... Also Lightbox will not come up instead it just links directly to Flick website when clicking on the photos. You can see it at

    I'm now also having this problem too, you can see it here:
    http://www.mypetninja.com/?page_id=28#sets

  6. DanCoulter
    Member
    Posted 5 years ago #

    fewpeople,

    On your page, the wp-e-commerce plugin is breaking it by loading a version of jQuery outside of the proper way to load jQuery on a WordPress page. You should either disable that plugin or contact the author of the plugin and ask him to update it to use wp_enqueue_script().

  7. DanCoulter
    Member
    Posted 5 years ago #

    For anyone else coming across an issue. It is almost always either another plugin or your theme that is loading a Javascript file outside of the wp_enqueue_script function that breaks it. The plugin works fine in 2.8. Try disabling other plugins one at a time until you find the one that is breaking it.

  8. fewpeople
    Member
    Posted 5 years ago #

    Hi Dan,

    Thanks for the reply, I tried disabling all the plugins (including wp-ecommerce) and I still get this problem where lightbox doesn't show and even the tabs dont' work. Any other ideas?

  9. DanCoulter
    Member
    Posted 5 years ago #

    Looking at your site again, it appears that jQuery is getting loaded three times:

    1. Plugins that use wp_enqueue_script()
    2. wp-e-commerce
    3. Your theme

    Any time that jQuery is loaded once it is already there will not only increase page load time, but it will wipe out any jQuery plugins loaded into the previous instance. My plugin's lightbox is one such jQuery plugin.

  10. Arroyero
    Member
    Posted 5 years ago #

    Exactly the same problem here. It was working fine until a couple of days ago. I can only think of the WP upgrade as an explanation. Now clicking takes you to the Flick website. The only other plugin Ive been working with recently is the Flshviewer for NextGen gallery, but the problem persists after disable them:

    Example

    BTW, your plugin is terific. I really apreciate your efforts to keep it uptodate.

  11. DanCoulter
    Member
    Posted 5 years ago #

    You have something that appears to insert links to "tags" in your articles. It is linking to arroyero.es. It overwrites "flickr" in one of the Javascript commands to a link to the flickr tag on that site. This breaks the Javascript.

  12. DanCoulter
    Member
    Posted 5 years ago #

    Oh, right, that domain is your site. Anyway, it's linking to your blog's tags and messing up the Javascript.

  13. hudson3709
    Member
    Posted 5 years ago #

    I am having the same issue kingit.ca I have tried disabling all of my plugins, as well as changing my theme and I still get the direct link to flickr, and no lightbox. Any ideas why this is occurring, or how we can check what is causing the Javascript error on our site?

  14. Arroyero
    Member
    Posted 5 years ago #

    Dan et al,

    It was so simple that I could not imagine why, but all I have to do is, following your tip, to remove the "flickr" tag from the post, and everything┬┤s back to normal. Still, a rather odd behaviour, and only surfaced after the 2.8 upgrade...

    Thanks for your support!

  15. DanCoulter
    Member
    Posted 5 years ago #

    @hudson3709: if you provide me with a link, I might be able to figure it out.

  16. darkpollo
    Member
    Posted 5 years ago #

    I have the same problem.
    Something has change since the latest upgrade of wordpress.

    My gallery is here.
    http://www.planetahuevo.es/mis-fotos/
    I have disabled all the plugins and still the problem.

    It has affect also other plugins with highslide so must be something with jquery, but i am not sure hwo to fix.

    Thank you for your help.

  17. OliverC
    Member
    Posted 5 years ago #

    Hello Dan,

    I am having the same issue. Any help or advice would be greatly appreciated:
    http://www.onestopenergy.com/photos/

    Thank you,
    Oliver

  18. DanCoulter
    Member
    Posted 5 years ago #

    OliverC,

    Try disabling the rest of your plugins temporarily. See if that solves the problem. If it doesn't, your theme might be adding Javascript that is messing with it.

    If you disable all of your plugins and switch to the default theme and still have the same problem, send me an email at the link below and I'll check it out as soon as I can:

    http://co.deme.me/contact/

  19. OliverC
    Member
    Posted 5 years ago #

    Hi Dan,

    You were correct! There was a plug-in called "WP Security Scan" that was causing the problem. In fact is was causing trouble somewhere else on my site too. I appreciate your help. I look forward to Collections being added as an option. I donated something to you (from @thingstocome)

    - Oliver

  20. macrunning
    Member
    Posted 4 years ago #

    Sorry so late to the party on this. I actually decided to back track and load 2.7 back on. It seems to cause the least amount of conflicts with the plugins I had. I also found that some plugins would cause compatibility issues with other plugins, mainly Flickr-Gallery. It is unfortunate there isn't more stability but I will deal with it because all of it put together (when running properly) kicks a**

  21. barthoogendijk
    Member
    Posted 4 years ago #

    It didn't work for me.. I am running 2.9.1
    My blog: http://www.levensbeschouwingalskunst.nl

    I tried Flickr-gallery, but it kept telling me the API was invalid format ( I tried six times; six different API's provided by Flickr)

    So.. currently I run Flickr-manager, but the same problem with lightbox and flickr plugins. It also just keeps popping up in different fora all around. I couldn't find an answer on any of them.

    @duping: I can see you had succes (!!) .. which version of wp are you running and with which plugins besides shadowbox and flickr-gallery

    any news for wp 2.9.2?
    or go for wp 2.7?

  22. barthoogendijk
    Member
    Posted 4 years ago #

    I think the author of another plugin Slickr Flickr solved the problem. A problem very similar is described on Russel Jamieson's website http://www.wordprise.com here. Maybe this insight can serve to get the other ones (flickr-gallery/flickr-manager etc in combination with lightbox) working too..

  23. webheadservice
    Member
    Posted 4 years ago #

    Hello,

    The Jquery Dropdown Menu plugin is breaking my Flickr Gallery lightbox, and I don't know how or what to edit to fix it. Has anyone else had issues with this combination who knows what I need to do? I get that it's something to do with jquery loading twice or something, but I need more help to know how to prevent that from happening.

    Thanks,

    Jacob

Topic Closed

This topic has been closed to new replies.

About this Topic