WordPress.org

Ready to get started?Download WordPress

Forums

Flexi Quote Rotator
Changing Title displayed on site from Quote Rotator (31 posts)

  1. Hopscotch Theatre
    Member
    Posted 2 years ago #

    I am trying to change the title of my Flexi Quote Rotator as it keeps displaying it as 'Quote Rotator' which doesn't look good on the site. I've tried changing the title within the Widget edit box and also in Settings where there is an option to change the title.. both have not worked and I'm wondering if there is another way to change the title?

    Thanks!

    http://wordpress.org/extend/plugins/flexi-quote-rotator/

  2. laughhearty
    Member
    Posted 2 years ago #

    I'm having the same issue. Anyone got a fix?

  3. laughhearty
    Member
    Posted 2 years ago #

    I got around this by using the Black Studio TinyMCE plugin and using the shortcode for Flexi Quote Rotator.
    Hopefully, there will be a more elegant solution to this problem...

  4. Hopscotch Theatre
    Member
    Posted 2 years ago #

    Hello laughhearty - thank you, that has worked! Much appreciated!

  5. mattpugs
    Member
    Posted 1 year ago #

    I am having the same issue, what shortcode did you use, I can't seem to make it work with the plugin you mentioned above.

  6. mattpugs
    Member
    Posted 1 year ago #

    Actually I was able to get it to work with the short code using the black studio plugin...however now it is displaying my title twice?

    edit - I was able to get it to display only once now but the title text is much larger then the other widgets I have in my footer. Anyone know how to fix?

    http://www.atnightdesign.com

  7. laughhearty
    Member
    Posted 1 year ago #

    Hi Mattpugs,
    add this to your CSS:

    .textwidget h2 {
        font-size: 15px;
        line-height: 50px;
        margin: 0 0 10px;
        padding: 0;
    }

    The text widget is giving heading as h2 the others are h3. The code above makes that specific h2 the same size as the h3's.

  8. mattpugs
    Member
    Posted 1 year ago #

    Thank you but I'm not sure if that will help, I actually have no idea what is causing it. Here is what I do know...with the black studio plugin if I add my title I want in the title field and put the shortcode [quoteRotator] in the text area it displays the title the normal size I want it but it also displays the title larger and underneath the smaller title...so weird.

    If I go back and completely remove the title from black studio it displays the large title text even though I have no title at all. Where is it pulling the title from if I don't have anything there? Ughhh so confusing...why can't this quote plugin just work like I did a few months ago.

  9. laughhearty
    Member
    Posted 1 year ago #

    Did you try my solution? It would work, actually.
    The reason why it's larger is because it's an h2 instead of an h3. You'd have to style the h2 in the text widget to be the same as the h3. Which is the code I gave you.

    But secondly are you including the title in your shortcode?

    [quoteRotator title="Testimonials" delay="8" fade="4" fadeout="2"]

    It should look like this if you don't want the title:

    [quoteRotator delay="8" fade="4" fadeout="2"]

    That may explain why the title is showing up twice when you title the TinyMCE.

  10. laughhearty
    Member
    Posted 1 year ago #

    Another thing if you added a title in the Flexi Quote settings it will show up. So you have to leave that blank.

  11. mattpugs
    Member
    Posted 1 year ago #

    Thats the problem with Flexi Quote...right now it won't let you change or even remove the title. Which is why the original user posted up this question. I'm not entirely good with coding myself, I tried adding the CSS but nothing changed for me at all.

  12. laughhearty
    Member
    Posted 1 year ago #

    Go into Flexi Quote settings. Not the widget. Go under settings in the left sidebar of your dashboard, you'll find flexi Quote. Click this. Check to see if you have a title in the first field. If you do, that's what's showing up.

  13. mattpugs
    Member
    Posted 1 year ago #

    Ahh that did it! Thank you for saving me more aggravation!

  14. brad1004
    Member
    Posted 1 year ago #

    Thanks laughhearty for posting your fix - works like a treat - Cheers

  15. rosieshilo
    Member
    Posted 1 year ago #

    What can't I change the title in the widget? It's driving me crazy.

  16. isle2isle
    Member
    Posted 1 year ago #

    I'm having the same problem. Any time I try and change anything in the widget it asks me if I'm sure I want to do this, and then I press save, but nothing saves. The title in both the widget AND the settings is blank, but Quote Rotator still shows up.

    Also, it is not validating.

  17. GeekSpecialties
    Member
    Posted 1 year ago #

    Same problem here, can't change the title in the widget.

  18. Greg Rickaby
    Member
    Posted 1 year ago #

    +1 can't change the title.

  19. akamaxbuz
    Member
    Posted 1 year ago #

    Same problem here. Can't change title in either the Widget or the Settings > Quote Rotator. Anybody got another quote plugin they like?

  20. isle2isle
    Member
    Posted 1 year ago #

    Yes. I ended up using Quotes Collection. Quick setup and validates!
    http://wordpress.org/extend/plugins/quotes-collection/

  21. rosieshilo
    Member
    Posted 1 year ago #

    Looks good isle2isle - thanks for the tip. Very frustrating that no response has been provided by the author.
    Cheers
    Rosie

  22. redkite
    Member
    Posted 1 year ago #

    Same problem here. That's too bad, I like Flexi Quotes. I wound up using Testimonials Widget, it works well.

  23. illustrata
    Member
    Posted 1 year ago #

    Same problem, started under WP 3.4.2. I have no title in the settings, and can't delete "quote rotator" title from the widget, or save a different font size. Message is "are you sure you want to do this?" and "Try again."

    Any hope?

  24. stevejohnson
    Member
    Posted 1 year ago #

    This plugin doesn't use the WordPress WidgetsAPI, presumably because the author's implementation (serving the quotes via javascript) doesn't allow for more than one instance.

    WP itself is blocking the updating of the widget options because of permissions.

  25. GeekSpecialties
    Member
    Posted 1 year ago #

    I switched to the Quotes Collection mentioned above. Works well.

  26. actionPackedAndy
    Member
    Posted 1 year ago #

    I switched from Quotes Collection because it's really heavy on admin-ajax.php calls, and actually caused my host to block it.

    I'd like to figure a fix for this dumb "Quote Rotator" title thing not working. I even tried changing the title in the quote-rotator.class.php file.

    Any other ideas?

  27. actionPackedAndy
    Member
    Posted 1 year ago #

    Actually, I think I figured out a way to do it...

    Open up the quote-rotator.class.php file under the classes folder, and change the title of the widget itself. Down towards the bottom it says ` function displayWidget($args)

    {

    extract($args);

    $options = get_option('widgetQuoteRotator');

    $title = $options['title'];'

    I deleted $options['title'] and put in what I wanted, and it worked. just leave $title =

    Not sure if it's a great fix, but it's a fix.

  28. Allimaple
    Member
    Posted 1 year ago #

    actionPackedAndy:

    Thank you for the tip, your solution worked perfectly.

  29. pl_london
    Member
    Posted 1 year ago #

    Worked for me too (once had removed the ; at the end of that line)

    Thanks

  30. natalie2
    Member
    Posted 1 year ago #

    I am new to this and was wondering if someone could help to figure out how to open up the quote-rotator.class.php file under the classes folder. I don't know quite what steps to follow to do this.
    Thank you

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic