WordPress.org

Ready to get started?Download WordPress

Forums

Flattr
[resolved] unable to handle IDN (international domain names) (3 posts)

  1. Witzman
    Member
    Posted 3 years ago #

    Hi.

    The flattr plugin does not work with IDNs.

    running my blog on http://www.netzgespräche.de (which will be resolved to http://www.xn--netzgesprche-ocb.de)
    Whe i enter these values in general settings WordPress address (URL) and Site address (URL) the blog is working.

    when trying to auth the plugin, no oauth token is generated.
    Link looks like this:
    https://api.flattr.com/oauth/authorize?oauth_token=&access_scope=read,readextended,click,publish
    In plugin settings callback domain = http://www.xn--netzgesprche-ocb.de

    when i change the URL (and all the settings in WP) to a non-IDN (www.witzman.de) everything works fine and a token is generated.

    http://wordpress.org/extend/plugins/flattr/

  2. Michael Henke
    Member
    Plugin Author

    Posted 3 years ago #

    This could be a API related issue. I'll forward it to Flattr and see if they know anything about it...

  3. Michael Henke
    Member
    Plugin Author

    Posted 2 years ago #

    Joel Hansson from Flattr checked:

    Hi.

    Sorry for taking so long.

    I'm unable to confirm the bug. I have no problem authenticating using the parsed name as callback.

    ie. exåmpel.flattr.local => http://xn--exmpel-jua.flattr.local

    that is, I use http://xn--exmpel-jua.flattr.loca when I register the app att flattr.com/apps and then use the same string as callback

    /Joel

    Hope it helps.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic