WordPress.org

Ready to get started?Download WordPress

Forums

Five Star Rating
[resolved] Great plugin, but getting an error (6 posts)

  1. AmyZealand
    Member
    Posted 3 years ago #

    Hi, I love this plugin. However, I'm getting an error after the vote is cast.

    I'm using Firefox 4.0.
    I've deactivated all other plugins.
    I'm using twentyten Theme.

    Any help would be much appreciated.

    The error is:

    Deprecated: Assigning the return value of new by reference is deprecated in C:\mysite\wp-content\plugins\five-star-rating\fsr-ajax-stars.php on line 6
    
    Deprecated: Assigning the return value of new by reference is deprecated in C:\mysite\wp-settings.php on line 204
    
    Deprecated: Assigning the return value of new by reference is deprecated in C:\mysite\wp-settings.php on line 219
    
    Deprecated: Assigning the return value of new by reference is deprecated in C:\mysite\wp-settings.php on line 226
    
    Deprecated: Assigning the return value of new by reference is deprecated in C:\mysite\wp-settings.php on line 233
    
    Deprecated: Assigning the return value of new by reference is deprecated in C:\mysite\wp-settings.php on line 258
    
    Deprecated: Function set_magic_quotes_runtime() is deprecated in C:\mysite\wp-settings.php on line 27

    http://wordpress.org/extend/plugins/five-star-rating/

  2. andrew.alba
    Member
    Plugin Author

    Posted 3 years ago #

    Glad you like the plugin and happy that you have actually used the troubleshooting tips.

    The error returned is caused by your instance of PHP. I am assuming you are running PHP 5.3 (maybe using XAMPP).

    If you look at line 6 of the /five-star-rating/fsr-ajax-stars.php file, you will see the following line:

    $FSR =& new FSR();

    Try removing the ampersand so the line looks like this.
    $FSR = new FSR();

    If that doesn't work, the only other option I would be aware of is changing your php.ini file in how it handles errors/notifications.

    You can get more information about the changes here http://www.php.net/manual/en/oop4.newref.php

  3. AmyZealand
    Member
    Posted 3 years ago #

    Hi Andrew,
    Thanks so much for your quick reply.
    You're 100% correct in that I'm using PHP 5.3 and XAMPP!

    Removing the & removed the first error, but still getting the other errors. Am not confident enough to play with php.ini file, but it shouldn't be a problem (hopefully) when I upload it anyway.

    However, I just tried it out on my 'test' blog, and it's now giving me a different problem. The star images are not showing. Any idea why? I followed you instructions on installing the plugin, and again tried deactivating other plugins.
    This is the link (sorry, the site looks horrible as its just my test one...) http://wanakahairdressers.co.nz/?p=145

  4. andrew.alba
    Member
    Plugin Author

    Posted 3 years ago #

    The css file and javascript file are not loading in the head of your document.

    There are several reasons why this could be happening, but the most common cause for this is your template and or the page you are using is missing the wp_head()

    <?php wp_head(); ?>

  5. AmyZealand
    Member
    Posted 3 years ago #

    Sorry!! Please ignore above post. It works perfectly in twentyten. It must have been the template.

    Thanks so much! This is a really fantastic plugin. Five Stars :-)

    Amy

  6. davemac
    Member
    Posted 3 years ago #

    So does this mean the plugin doesn't work in PHP5?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic