WordPress.org

Ready to get started?Download WordPress

Forums

File Gallery
Problems after WP upgrade to 3.1 (9 posts)

  1. smilenj
    Member
    Posted 3 years ago #

    Hi there -

    Love FG plugin but I just upgraded to 3.1 and it doesn't seem to work. The problems I see:

    * When I save a post I get a error message that says only "undefined"
    * I am unable to add any images via the "gallery" or "single files" buttons. Nothing happens
    * I am unable to edit/change tags when I pull up the standard WP "Add Media" box

    Anyone have suggestions?

  2. Aesqe
    Member
    Plugin Author

    Posted 3 years ago #

    Hi smilenj,

    I've tested File Gallery v1.6.5.4 with WordPress 3.1 and I don't get any errors, I'm sorry to hear that you do :/

    Could you please tell me what version of File Gallery you have installed and which browser (and version) you are using?

    Also, if you can, it would help if you could test File Gallery on its own - with all other plugins deactivated - and see if you still get errors.

    Thanks!

    Bruno

  3. security_man
    Member
    Posted 3 years ago #

    i am having the same problem. the version is 1.6.5.4 and wordpress 3.1 the undefined error (i think) is a javascript error and it is across all browsers (ie, firefox, chrome) and operating systems (windows xp, 7)

    and yes, with all other plugins turned off it still has the undefined error popup

    also i assume you know that in IE the buttons on each of the thumbnails at the bottom do not show up, but that was a problem before the undefined thing happened.

  4. Aesqe
    Member
    Plugin Author

    Posted 3 years ago #

    @smilenj, @security_man: please try version 1.7 of the plugin and tell me if the problem persists - here's a copy / paste from another post:

    I've uploaded v1.7 to the trunk (development version), so please download it from here: http://downloads.wordpress.org/plugin/file-gallery.zip and see if everything works OK after upgrade.

    Please update like this:
    1) on the media settings page, make sure that the option "Delete all options on deactivation?" is NOT checked
    2) deactivate current version of the plugin
    3) delete current version of the plugin via WordPress interface, or just overwrite files on the server via FTP
    4) upload File Gallery 1.7 either via WordPress interface, or via FTP
    5) activate new version

    Thank you very much in advance, it helps me a lot when people test new versions before they are released to public :)

    Aesqe

  5. Aesqe
    Member
    Plugin Author

    Posted 3 years ago #

    @security_man: regarding missing buttons in MSIE (I'm assuming version 7?), that's been fixed in 1.7 as well

  6. security_man
    Member
    Posted 3 years ago #

    undefined error is still popping up on multiple browsers, but the buttons in IE7 have been fixed.

    Really great plugin btw, dont wanna poop on the whole thing :)

  7. Aesqe
    Member
    Plugin Author

    Posted 3 years ago #

    @security_man: could you please send me a screenshot? that would help me a lot, thanks :)

  8. security_man
    Member
    Posted 3 years ago #

    well, its just a popup similar to the javascript alert function. all it says is "undefined" as soon as you load the edit page or edit post pages in the admin

  9. Aesqe
    Member
    Plugin Author

    Posted 3 years ago #

    OK, here goes the stupidest question of all: does it still pop up if you disable File Gallery?

    Sorry, but I'm all out of ideas... :/

    One other thing you could do is take a look at the "Error console" in Firefox. If it's enabled, it will be available from the Tools menu. If not, then please follow these instructions on how to enable it: https://developer.mozilla.org/en/Error_Console.

    So, open the Error console and click the Clear button.

    Now open/refresh the page that pops the alert box and see if any error has been logged. If it has, then please paste it here.

    It probably won't show anything, but, like I said, I'm all out of ideas...

    If it's an option for you, smilenj and security_man, I'll gladly take a look at your site's backends and try to solve the mystery, and I'm guessing it would not take me more than 5 minutes.

    You can contact me either via e-mail (aesqe at skyphe dot org) or skype (username: skyphe).

    thanks :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic