WordPress.org

Ready to get started?Download WordPress

Forums

File Gallery
[resolved] breaks install "undefined function wp_get_current_user()" (4 posts)

  1. ptroxler
    Member
    Posted 3 years ago #

    wow --- have not had this for a while --- this plugin sucks!

  2. Aesqe
    Member
    Plugin Author

    Posted 3 years ago #

    hi ptroxler

    it would really help if you could give me some data to work with, like wordpress and file gallery versions.

    does this happen on wordpress installation, wordpress upgrade, plugin activation, in the admin, in the frontend, both...?

    how are you certain that file gallery is the culprit?

    thanks :)

  3. ptroxler
    Member
    Posted 3 years ago #

    how I am certain ... you never are, yet gallery breaks a relatively juvenile install of 3.0.1 with no other plugin than admin language installed -- hmm, which indeed could cause an incompatibility to your gallery ... you might want to investigate :)

  4. Aesqe
    Member
    Plugin Author

    Posted 3 years ago #

    so did you try activating just "file gallery" without activating "admin language" plugin? :D

    i've investigated and found out a few things:

    1) "admin language" could be the bigger culprit here because it seems that it's calling the function 'get_user_option' too soon ('locale' filter is located in 'l10n.php' file which is loaded before 'user.php' file in which 'get_user_option' function resides) - i'll contact the author
    2) "admin language" is breaking plugin translations by returning 'false' instead of '$locale' in one place
    2) i should move the load_plugin_textdomain call to 'init' hook for better compatibility with other plugins

    thanks for reporting this ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic