WordPress.org

Ready to get started?Download WordPress

Forums

FG Joomla to WordPress
[resolved] Can't import images/media - Unable to acess (11 posts)

  1. bvstrien
    Member
    Posted 1 year ago #

    Hi i have Joomla 1.5 and trying you're plugin to import/migrate to WordPress. All goed fine, except the images. I have already seen some import image problems and sollution on this forum, but didn't see my error notification:

    [fgj2wp] Can't copy http://www.website.nl/site/images/stories/fasefotos/Week1.JPG to /mounted-storage/home108b/sub003/sc48696-NCDL/website.nl/wpsite/wp-content/uploads/Week1.JPG : copy() [function.copy]: Unable to access http://www.website.nl/site/images/stories/fasefotos/Week1.JPG

    Could you please tell me how to solve this problem? I already tried the sollution which i have read, but they didn't work so far.

    http://wordpress.org/extend/plugins/fg-joomla-to-wordpress/

  2. Kerfred
    Member
    Plugin Author

    Posted 1 year ago #

    That is because when you click on http://www.website.nl/site/images/stories/fasefotos/Week1.JPG, you are redirected to http://www.telegraaf.nl/ And this is not an image.
    You can have a look at your .htaccess file to find out the cause of this behavior.

  3. bvstrien
    Member
    Posted 1 year ago #

    Off course, that's because i changed the URL, because it pointed to a private picture :) The original URL works like a charm.

    What could be found in the .htaccess file which could be wrong?

  4. Kerfred
    Member
    Plugin Author

    Posted 1 year ago #

    The .htaccess file contains rewrite rules.
    But in your case, you have found the solution: the private images are private and are not accessible by WordPress.

  5. bvstrien
    Member
    Posted 1 year ago #

    i think you don't understand. It are just normal images, but because they are private i'm not pasting the original URL. I can access when typing the correct URL in the browser, so that's not the problem.

    So i think wordpress just should be able to access them....but why can't it? Is there something that should be turned of??

  6. Kerfred
    Member
    Plugin Author

    Posted 1 year ago #

    Did you put «http://» in the URL field in the plugin settings ?

  7. bvstrien
    Member
    Posted 1 year ago #

    yes i did, could it have something to do with safe mode on php on the server?

  8. bvstrien
    Member
    Posted 1 year ago #

    Or could the port be different?

  9. Kerfred
    Member
    Plugin Author

    Posted 1 year ago #

    I don't know. You can try to deactivate the safe mode.
    Or you can try to import your Joomla site (database + images) on localhost, install WordPress on localhost and do the migration from there.

  10. bvstrien
    Member
    Posted 1 year ago #

    hi, i'll give both options a shot. I'll let ya know

  11. bvstrien
    Member
    Posted 1 year ago #

    it was the safe mode on the server. After putting it off, it worked like a charm! Thanx!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.