WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Featurific For WordPress] Produces xml links that (6 posts)

  1. houseofstrauss
    Member
    Posted 6 years ago #

    Google reports several 404 from URLs like this
    http://mydomain.com/wp-content/plugins/featurific-for-wordpress/data_1215095866.xml
    Why are these being generated and how do I stop them?

    http://wordpress.org/extend/plugins/featurific-for-wordpress/

  2. rinogo
    Member
    Posted 6 years ago #

    Hi houseofstrauss!

    My name is Rich, and I'm the author of the Featurific for WordPress plugin. Can you provide me with a URL to your blog so that I can diagnose the problem directly? Also, I'm not sure I fully understand what you mean by Google reporting several 404 URLs. Could you explain a bit more?

    THanks! :)

  3. houseofstrauss
    Member
    Posted 6 years ago #

    Hi Rich. Here is one particular URL of about 40 similar.
    http://myzerowaste.com/wp-content/plugins/featurific-for-wordpress/data_1217234443.xml I have loads of these in my Google site crawl report and they all give a 404 in google. I have plugged the hole in my htaccess to prevent google crawling my files and directories, so this probably won't happen again. Thought you needed to know about this, however as other users may not be locking down their site files so tightly.

  4. rinogo
    Member
    Posted 6 years ago #

    Hey again, house!

    So, I wrote a lengthy response to this post and submitted it to wordpress.org, but it never appeared here...So strange. So, I'll try to duplicate what I wrote before, in a sort of executive summary form.

    It seems that google is parsing the javascript code that is used to embed featurific, parsing out the location of the XML file and adding it to its index. However, we don't really want this to happen because the filename of the XML changes every x minutes (according to the data.xml generation frequency you've set in the Featurific Settings). (We have to change the filename in order for the XML to not be cached by users' browsers).

    I think the best way to fix this is as you've done, with the .htaccess file. Could you post your changes to your .htaccess file here so that we can share them with other users who would like to fix the problem?

  5. houseofstrauss
    Member
    Posted 6 years ago #

    I used a robots file as found here http://blog.maddozza.com/wordpress-duplicate-content/16/ which is supposed to exclude bots from various parts of the file system, including /plugins/ However, checking my google index results recently proves that this has NOT worked and the xml files are still being parsed. I still have 38 xml files not found by Google bot. So ... still looking for a solution.

  6. rinogo
    Member
    Posted 5 years ago #

    Hi house,

    It's been a while since we addressed this issue. Are you still having problems?

    Thanks! :)
    -Rich

Topic Closed

This topic has been closed to new replies.

About this Topic