WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Featurific For WordPress] Play nice with NextGen Gallery? (10 posts)

  1. louzucaro
    Member
    Posted 6 years ago #

    Hi...any chance you could make this a bit more NextGen Gallery-aware? Specifically, if I have a single picture included in a post, there's a [singlepic,,,,] tag for NGG that shows up in the Featurific text, which kinda stinks.

    There's also a weird thing where sometimes if a post has a NGG gallery at the front, the gallery tag doesn't appear in the Featurific text, which is good, but some other text appears and I'm not sure where it's coming from.

    For instance, the post in my #1 spot is currently about LEGO, but the text shown in Featurific has the text "iPhone 3G" at the beginning, which doesn't appear anywhere in the post.

  2. rinogo
    Member
    Posted 6 years ago #

    Hi louzucaro!

    Hmm...That's interesting. The plugin has already been coded so that shortcodes are removed:

    //Process any shortcodes, converting them into their resulting HTML.
    		if(function_exists('do_shortcode'))
    			$posts[$post_id]['post_content'] = do_shortcode($posts[$post_id]['post_content']);

    Could you provide me with a URL I can take a look at to investigate a bit more?

    Thanks! :)

  3. louzucaro
    Member
    Posted 6 years ago #

    Yes, you can see at http://www.pause.com/

    You'll see on the first one (currently) there's no shortcode, but on the next ones you see it.

    Thanks!

    Lou

  4. rinogo
    Member
    Posted 6 years ago #

    Hmmm, that's odd...I'm not sure why the shortcode would not be executed and removed, and it looks like you're using the most recent version of the plugin. I'll download simplepic and see if I can reproduce the problem in my debugging environment.

    P.S. Love the blog! The post on Emily blew me away.

  5. louzucaro
    Member
    Posted 6 years ago #

    Thanks! We're going to be interviewing her soon :)

    Lou

    P.S. You probably know this, but just in case, I'm not using simplepic directly, but NextGen Gallery...the shortcode is for their 'singlepic' (as opposed to simplepic)

  6. rinogo
    Member
    Posted 6 years ago #

    Hey Lou,

    I've done some debugging and further development. I'm not quite ready to release this version yet, but thought you might give it a try and see if it fixes the problem for you. Please let me know if it does/doesn't! :)

    http://featurific.com/files/featurific-for-wordpress-1.4.0.zip

    Have a great day!
    -RIch

  7. louzucaro
    Member
    Posted 6 years ago #

    Hey, thanks a bunch!

    I uploaded it, deactivated / reactivated it but it still seems to be doing the same thing.

    I really appreciate you looking into this and providing that link!

    P.S. WP does show the version as 1.4.0, just FYI

    Lou

  8. rinogo
    Member
    Posted 5 years ago #

    Hi Lou,

    Are you still having this problem? We've released several new versions since we had this discussion, and I'm wondering if we've fixed the problem. Let me know.

    Thanks! :)
    -Rich

  9. xxsq
    Member
    Posted 5 years ago #

    Any solution to this yet?
    I'm running the latest version of Futurific, but still same problem, doesnt recognize the gallery.

  10. rinogo
    Member
    Posted 5 years ago #

    Hi xxsq,

    Can you explain the problem that you're having a bit more? It seems like you might be having a slightly different problem than Lou had.

    Also, if you post your response on our support forum, we'll be able to answer your question in a much speedier manner:

    http://featurific.com/support

    Thanks, and have a great day!
    -Rich

Topic Closed

This topic has been closed to new replies.

About this Topic