WordPress.org

Ready to get started?Download WordPress

Forums

Featured Content Showcase
nothing showing up in ie6,ie7,ie8 (4 posts)

  1. robfelty
    Member
    Posted 3 years ago #

    using default twenty ten theme

    http://wordpress.org/extend/plugins/featured-content-showcase/

    If I unset the visibility:hidden, I see the featured posts, but the javascript stuff is not working.

  2. robfelty
    Member
    Posted 3 years ago #

    I fixed it. It turns out that it was an extra comma in the galleryView options. To fix it - in featured-content-showcase.php look for galleryView({

    replace that line all the way to the matching
    })
    with:

    jQuery('#photos').galleryView({
    <?php
        $i=1;
        $comma=',';
        foreach ( $this->_settings['featured-content-showcase'] as $setting => $value ) {
          if ($i==count($this->_settings['featured-content-showcase']))
            $comma='';
          if ( !in_array($setting, array('use_fcs_css', 'filmstrip_margin') ) ) {
            if ( is_string($value) ) {
              $value = "'" . esc_js($value) . "'";
            } elseif ( is_bool($value) ) {
              $value = ($value)? 'true':'false';
            }
            if ( strpos( $setting, 'opacity' ) !== false ) {
              $value /= 100;
            }
            echo "{$setting}: {$value}$comma\r\n";
          }
          $i++;
        }
    ?>
              });
  3. shane_tactical1
    Member
    Posted 3 years ago #

    Thanks for this man! I couldnt figure out why it didnt work in IE7 but worked in Firefox. I did the same thing with the visibility hidden and couldnt figure it out so cheers! Saved me a few hours im sure.

  4. Aaron D. Campbell
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry that I missed this. Version 0.2.4 (already checked in...should be available in about 15 minutes) fixes this issue

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic